summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-22 09:38:34 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-22 10:04:14 +0200
commit5fe0543b09ae58242b6ecd94e21400436c03a8f3 (patch)
treedb387dfd8f64ae58c7b9fa82304f2423702c6914
parentapp-editors/bluefish: Eradicate python2 support (diff)
downloadgentoo-5fe0543b09ae58242b6ecd94e21400436c03a8f3.tar.gz
gentoo-5fe0543b09ae58242b6ecd94e21400436c03a8f3.tar.bz2
gentoo-5fe0543b09ae58242b6ecd94e21400436c03a8f3.zip
mail-client/claws-mail: Eradicate python2
Closes: https://bugs.gentoo.org/698984 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--mail-client/claws-mail/claws-mail-3.17.6-r1.ebuild16
-rw-r--r--mail-client/claws-mail/claws-mail-9999.ebuild14
2 files changed, 6 insertions, 24 deletions
diff --git a/mail-client/claws-mail/claws-mail-3.17.6-r1.ebuild b/mail-client/claws-mail/claws-mail-3.17.6-r1.ebuild
index 86b3570227ef..6274cc62b9fc 100644
--- a/mail-client/claws-mail/claws-mail-3.17.6-r1.ebuild
+++ b/mail-client/claws-mail/claws-mail-3.17.6-r1.ebuild
@@ -3,8 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 )
-inherit autotools desktop python-single-r1 xdg
+inherit autotools desktop xdg
DESCRIPTION="An email client (and news reader) based on GTK+"
HOMEPAGE="https://www.claws-mail.org/"
@@ -20,14 +19,13 @@ fi
SLOT="0"
LICENSE="GPL-3"
-IUSE="+appindicator archive bogofilter calendar clamav dbus debug dillo doc gdata +gnutls +imap ipv6 ldap +libcanberra +libnotify litehtml networkmanager nls nntp +notification pdf perl +pgp python rss session sieve smime spamassassin spam-report spell startup-notification svg valgrind xface"
+IUSE="+appindicator archive bogofilter calendar clamav dbus debug dillo doc gdata +gnutls +imap ipv6 ldap +libcanberra +libnotify litehtml networkmanager nls nntp +notification pdf perl +pgp rss session sieve smime spamassassin spam-report spell startup-notification svg valgrind xface"
REQUIRED_USE="
appindicator? ( notification )
libcanberra? ( notification )
libnotify? ( notification )
networkmanager? ( dbus )
- python? ( ${PYTHON_REQUIRED_USE} )
smime? ( pgp )
"
@@ -100,10 +98,6 @@ RDEPEND="${COMMONDEPEND}
networkmanager? ( net-misc/networkmanager )
pdf? ( app-text/ghostscript-gpl )
perl? ( dev-lang/perl:= )
- python? (
- ${PYTHON_DEPS}
- >=dev-python/pygtk-2.10.3
- )
rss? (
dev-libs/libxml2
net-misc/curl
@@ -114,10 +108,6 @@ PATCHES=(
"${FILESDIR}/${PN}-3.17.5-enchant-2_default.patch"
)
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
src_prepare() {
xdg_src_prepare
eautoreconf
@@ -163,7 +153,7 @@ src_configure() {
$(use_enable pgp pgpcore-plugin)
$(use_enable pgp pgpinline-plugin)
$(use_enable pgp pgpmime-plugin)
- $(use_enable python python-plugin)
+ --disable-python-plugin
$(use_enable rss rssyl-plugin)
$(use_enable session libsm)
$(use_enable sieve managesieve-plugin)
diff --git a/mail-client/claws-mail/claws-mail-9999.ebuild b/mail-client/claws-mail/claws-mail-9999.ebuild
index 3633ad0400de..c2818293f810 100644
--- a/mail-client/claws-mail/claws-mail-9999.ebuild
+++ b/mail-client/claws-mail/claws-mail-9999.ebuild
@@ -3,8 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 )
-inherit autotools desktop python-single-r1 xdg
+inherit autotools desktop xdg
DESCRIPTION="An email client (and news reader) based on GTK+"
HOMEPAGE="https://www.claws-mail.org/"
@@ -20,13 +19,12 @@ fi
SLOT="0"
LICENSE="GPL-3"
-IUSE="+appindicator archive bogofilter calendar clamav dbus debug dillo doc gdata +gnutls gtk2 +imap ipv6 ldap +libcanberra +libnotify litehtml networkmanager nls nntp +notification pdf perl +pgp python rss session sieve smime spamassassin spam-report spell startup-notification svg valgrind xface"
+IUSE="+appindicator archive bogofilter calendar clamav dbus debug dillo doc gdata +gnutls gtk2 +imap ipv6 ldap +libcanberra +libnotify litehtml networkmanager nls nntp +notification pdf perl +pgp rss session sieve smime spamassassin spam-report spell startup-notification svg valgrind xface"
REQUIRED_USE="
appindicator? ( notification )
libcanberra? ( notification )
libnotify? ( notification )
networkmanager? ( dbus )
- python? ( ${PYTHON_REQUIRED_USE} )
smime? ( pgp )
"
@@ -100,10 +98,6 @@ RDEPEND="${COMMONDEPEND}
networkmanager? ( net-misc/networkmanager )
pdf? ( app-text/ghostscript-gpl )
perl? ( dev-lang/perl:= )
- python? (
- ${PYTHON_DEPS}
- >=dev-python/pygtk-2.10.3
- )
rss? (
dev-libs/libxml2
net-misc/curl
@@ -115,8 +109,6 @@ PATCHES=(
)
pkg_setup() {
- use python && python-single-r1_pkg_setup
-
if [[ "${PV}" == *9999 ]] && ! use gtk2 ; then
EGIT_BRANCH="gtk3"
fi
@@ -167,7 +159,7 @@ src_configure() {
$(use_enable pgp pgpcore-plugin)
$(use_enable pgp pgpinline-plugin)
$(use_enable pgp pgpmime-plugin)
- $(use_enable python python-plugin)
+ --disable-python-plugin
$(use_enable rss rssyl-plugin)
$(use_enable session libsm)
$(use_enable sieve managesieve-plugin)