summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-12 09:20:24 +0000
committerSam James <sam@gentoo.org>2024-01-12 09:21:50 +0000
commit6016f0772a62899d691b16037b4ec41289ba9e0e (patch)
tree436736ca1fcaf44404dd169f3ab55a0b261d738d
parentkde-apps/kate-addons: fix no-PCH build (diff)
downloadgentoo-6016f0772a62899d691b16037b4ec41289ba9e0e.tar.gz
gentoo-6016f0772a62899d691b16037b4ec41289ba9e0e.tar.bz2
gentoo-6016f0772a62899d691b16037b4ec41289ba9e0e.zip
kde-apps/kwrite: fix no-PCH build
Closes: https://bugs.gentoo.org/921720 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--kde-apps/kwrite/files/kate-23.08.4-no-pch.patch58
-rw-r--r--kde-apps/kwrite/kwrite-23.08.4.ebuild4
2 files changed, 62 insertions, 0 deletions
diff --git a/kde-apps/kwrite/files/kate-23.08.4-no-pch.patch b/kde-apps/kwrite/files/kate-23.08.4-no-pch.patch
new file mode 100644
index 000000000000..89ef142fbd2c
--- /dev/null
+++ b/kde-apps/kwrite/files/kate-23.08.4-no-pch.patch
@@ -0,0 +1,58 @@
+https://bugs.gentoo.org/921720
+https://invent.kde.org/utilities/kate/-/issues/116
+https://invent.kde.org/utilities/kate/-/merge_requests/1387
+
+From 83fcf7b4e7cc7bc54828192e9b89cfb286d864fd Mon Sep 17 00:00:00 2001
+From: Aleix Pol <aleixpol@kde.org>
+Date: Tue, 19 Sep 2023 16:34:49 +0200
+Subject: [PATCH] Fix build
+
+Ever since I last updated, I've started to get errors about includes
+missing, so I've added them.
+
+(cherry picked from commit 73d090f7f7cb7cc013f31c7b572ca78a7fbeb5b8)
+---
+ addons/git-blame/kategitblameplugin.h | 1 +
+ addons/project/git/gitstatus.h | 1 +
+ apps/lib/ktexteditor_utils.h | 2 ++
+ 3 files changed, 4 insertions(+)
+
+diff --git a/addons/git-blame/kategitblameplugin.h b/addons/git-blame/kategitblameplugin.h
+index 0a87f700e8..4c3d4a977f 100644
+--- a/addons/git-blame/kategitblameplugin.h
++++ b/addons/git-blame/kategitblameplugin.h
+@@ -20,6 +20,7 @@
+ #include <QLocale>
+ #include <QPointer>
+ #include <QTimer>
++#include <QUrl>
+ #include <QVariant>
+ #include <QVector>
+
+diff --git a/addons/project/git/gitstatus.h b/addons/project/git/gitstatus.h
+index 7caad963eb..dcf01b66c9 100644
+--- a/addons/project/git/gitstatus.h
++++ b/addons/project/git/gitstatus.h
+@@ -5,6 +5,7 @@
+ */
+ #pragma once
+
++#include <QSet>
+ #include <QString>
+ #include <QVector>
+
+diff --git a/apps/lib/ktexteditor_utils.h b/apps/lib/ktexteditor_utils.h
+index ac3f218870..d9d4e6fdaa 100644
+--- a/apps/lib/ktexteditor_utils.h
++++ b/apps/lib/ktexteditor_utils.h
+@@ -7,6 +7,8 @@
+ #include "kateprivate_export.h"
+
+ #include <QString>
++#include <QUrl>
++#include <QWidgetList>
+
+ QT_BEGIN_NAMESPACE
+ class QScrollBar;
+--
+GitLab
diff --git a/kde-apps/kwrite/kwrite-23.08.4.ebuild b/kde-apps/kwrite/kwrite-23.08.4.ebuild
index 3b86e6b4e7ad..293ee80d2170 100644
--- a/kde-apps/kwrite/kwrite-23.08.4.ebuild
+++ b/kde-apps/kwrite/kwrite-23.08.4.ebuild
@@ -28,6 +28,10 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/kate-23.08.4-no-pch.patch
+)
+
src_prepare() {
ecm_src_prepare