summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-12-30 20:07:30 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-12-30 20:17:20 +0100
commit6053ed3a3d3178ef3260734ae6c6776e2b02789f (patch)
treeb016fa514230f32d5389ffb341ce1b7cd9722dd6
parentmedia-video/mpv: sync live keywords (diff)
downloadgentoo-6053ed3a3d3178ef3260734ae6c6776e2b02789f.tar.gz
gentoo-6053ed3a3d3178ef3260734ae6c6776e2b02789f.tar.bz2
gentoo-6053ed3a3d3178ef3260734ae6c6776e2b02789f.zip
dev-python/django-debug-toolbar: PythonCompatUpdate
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-4.2.0-r1.ebuild (renamed from dev-python/django-debug-toolbar/django-debug-toolbar-4.2.0.ebuild)4
-rw-r--r--dev-python/django-debug-toolbar/files/django-debug-toolbar-4.2.0-py312.patch20
2 files changed, 23 insertions, 1 deletions
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-4.2.0.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-4.2.0-r1.ebuild
index 570f8b5e767c..31ff14e414eb 100644
--- a/dev-python/django-debug-toolbar/django-debug-toolbar-4.2.0.ebuild
+++ b/dev-python/django-debug-toolbar/django-debug-toolbar-4.2.0-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
@@ -30,6 +30,8 @@ BDEPEND="
)
"
+PATCHES=( "${FILESDIR}"/${P}-py312.patch )
+
python_test() {
"${EPYTHON}" -m django test -v 2 --settings tests.settings \
|| die "Tests failed with ${EPYTHON}"
diff --git a/dev-python/django-debug-toolbar/files/django-debug-toolbar-4.2.0-py312.patch b/dev-python/django-debug-toolbar/files/django-debug-toolbar-4.2.0-py312.patch
new file mode 100644
index 000000000000..69a5558da31b
--- /dev/null
+++ b/dev-python/django-debug-toolbar/files/django-debug-toolbar-4.2.0-py312.patch
@@ -0,0 +1,20 @@
+--- a/tests/panels/test_profiling.py 2023-12-30 20:02:22.263807899 +0100
++++ b/tests/panels/test_profiling.py 2023-12-30 20:03:44.655458186 +0100
+@@ -1,3 +1,6 @@
++import sys
++import unittest
++
+ from django.contrib.auth.models import User
+ from django.db import IntegrityError, transaction
+ from django.http import HttpResponse
+@@ -50,6 +53,10 @@
+ self.assertNotIn("render", content)
+ self.assertValidHTML(content)
+
++ @unittest.skipUnless(
++ sys.version_info < (3, 12, 0),
++ "Python 3.12 no longer contains a frame for list comprehensions.",
++ )
+ def test_listcomp_escaped(self):
+ self._get_response = lambda request: listcomp_view(request)
+ response = self.panel.process_request(self.request)