summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2021-03-11 17:47:29 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2021-03-11 17:47:59 +0100
commit605c5beb55c31c37bd61b48086e8c5d66504d917 (patch)
treee7dd6f3601744192edf437e001350343aeba3d4b
parentsys-apps/file: allow futex() syscall unconditionally (diff)
downloadgentoo-605c5beb55c31c37bd61b48086e8c5d66504d917.tar.gz
gentoo-605c5beb55c31c37bd61b48086e8c5d66504d917.tar.bz2
gentoo-605c5beb55c31c37bd61b48086e8c5d66504d917.zip
media-radio/gpredict: Version bump
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
-rw-r--r--media-radio/gpredict/Manifest1
-rw-r--r--media-radio/gpredict/files/gpredict-2.3-doc.patch15
-rw-r--r--media-radio/gpredict/gpredict-2.3.ebuild36
3 files changed, 52 insertions, 0 deletions
diff --git a/media-radio/gpredict/Manifest b/media-radio/gpredict/Manifest
index 76be9c141737..23513bc7a616 100644
--- a/media-radio/gpredict/Manifest
+++ b/media-radio/gpredict/Manifest
@@ -1 +1,2 @@
DIST gpredict-2.2.1.tar.bz2 4647342 BLAKE2B 989b80fd0f0029551854c18c1e00bd5d223bffe4aa20004b828bec87ab56dd488edf4d62289d394225e2a6b0c89ca1c9962cf63afe076a355757371127712ea7 SHA512 590a218bc95a465ca9772f892b77763b92a6c41c7d9f3b48279f28916cef8a5bfe616e6cdda1002e7dda082f37f37a98af8c8180895c572fec9c96aa76888f5d
+DIST gpredict-2.3.tar.gz 7742902 BLAKE2B 1ff567871838b062c59ab0076330a354afee082506044f5ce2ae1c7553e7f3462770f7134d13e3b603f7966476d13b365dd3575cc6c7e32d23865ba29b602cc9 SHA512 d7434aff482c943951a79cb607c91f118cfbde8209b4b370d0d2147766244fab2839b5c712864c2c521635f31c484ef2bfd3c771371e946f5a3561801ab474b5
diff --git a/media-radio/gpredict/files/gpredict-2.3-doc.patch b/media-radio/gpredict/files/gpredict-2.3-doc.patch
new file mode 100644
index 000000000000..960a6387322f
--- /dev/null
+++ b/media-radio/gpredict/files/gpredict-2.3-doc.patch
@@ -0,0 +1,15 @@
+diff --git a/Makefile.am b/Makefile.am
+index d807d7f..ca80839 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -9,10 +9,6 @@ dist-hook:
+
+ install-data-local:
+ @$(NORMAL_INSTALL)
+- $(INSTALL_DATA) $(top_srcdir)/AUTHORS $(DESTDIR)$(pkgdatadir)
+- $(INSTALL_DATA) $(top_srcdir)/NEWS $(DESTDIR)$(pkgdatadir)
+- $(INSTALL_DATA) $(top_srcdir)/README $(DESTDIR)$(pkgdatadir)
+- $(INSTALL_DATA) $(top_srcdir)/COPYING $(DESTDIR)$(pkgdatadir)
+
+ EXTRA_DIST = \
+ autogen.sh \
diff --git a/media-radio/gpredict/gpredict-2.3.ebuild b/media-radio/gpredict/gpredict-2.3.ebuild
new file mode 100644
index 000000000000..41323787c2a8
--- /dev/null
+++ b/media-radio/gpredict/gpredict-2.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Real-time satellite tracking and orbit prediction application"
+HOMEPAGE="http://gpredict.oz9aec.net"
+SRC_URI="https://github.com/csete/gpredict/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ x11-libs/gdk-pixbuf[jpeg]
+ x11-libs/gtk+:3
+ x11-libs/goocanvas:2.0
+ net-misc/curl"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+DOCS=( AUTHORS NEWS README )
+
+src_prepare() {
+ eapply_user
+ # remove wrong doc location
+ eapply "${FILESDIR}/${P}-doc.patch"
+ eapply "${FILESDIR}/${PN}-2.2.1-fno-common.patch"
+
+ sed -i -e "s+./configure +# ./configure +g" autogen.sh || die
+
+ ./autogen.sh
+}