summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-09 09:59:06 +0200
committerDavid Seifert <soap@gentoo.org>2022-09-09 09:59:06 +0200
commit607d4633779554b5b8dba6c7db163b3710234556 (patch)
treed3cf71bc02b47623351e3c90fb4f18669c6b6386
parentdev-libs/nsync: drop multilib (diff)
downloadgentoo-607d4633779554b5b8dba6c7db163b3710234556.tar.gz
gentoo-607d4633779554b5b8dba6c7db163b3710234556.tar.bz2
gentoo-607d4633779554b5b8dba6c7db163b3710234556.zip
dev-libs/onigmo: drop multilib, static-libs
No multilib or static-libs reverse dependencies. Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-libs/onigmo/onigmo-6.2.0-r1.ebuild35
-rw-r--r--dev-libs/onigmo/onigmo-6.2.0.ebuild34
2 files changed, 35 insertions, 34 deletions
diff --git a/dev-libs/onigmo/onigmo-6.2.0-r1.ebuild b/dev-libs/onigmo/onigmo-6.2.0-r1.ebuild
new file mode 100644
index 000000000000..66151a7a8e68
--- /dev/null
+++ b/dev-libs/onigmo/onigmo-6.2.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Onigmo is a regular expressions library forked from Oniguruma"
+HOMEPAGE="https://github.com/k-takata/Onigmo"
+SRC_URI="https://github.com/k-takata/${PN^o}/releases/download/${P^o}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/6"
+KEYWORDS="amd64 x86"
+IUSE="combination-explosion-check crnl-as-line-terminator"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable combination-explosion-check) \
+ $(use_enable crnl-as-line-terminator)
+}
+
+src_install() {
+ default
+
+ dodoc doc/{API,FAQ,RE}{,.ja} doc/UnicodeProps.txt
+
+ find "${ED}" -name "*.la" -delete || die
+}
diff --git a/dev-libs/onigmo/onigmo-6.2.0.ebuild b/dev-libs/onigmo/onigmo-6.2.0.ebuild
deleted file mode 100644
index 21ef5b828dbc..000000000000
--- a/dev-libs/onigmo/onigmo-6.2.0.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit autotools multilib-minimal
-
-DESCRIPTION="Onigmo is a regular expressions library forked from Oniguruma"
-HOMEPAGE="https://github.com/k-takata/Onigmo"
-SRC_URI="https://github.com/k-takata/${PN^o}/releases/download/${P^o}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0/6"
-KEYWORDS="amd64 x86"
-IUSE="combination-explosion-check crnl-as-line-terminator static-libs"
-
-DOCS=( AUTHORS HISTORY README{,.ja} doc/{API,FAQ,RE}{,.ja} doc/UnicodeProps.txt )
-
-src_prepare() {
- default
- eautoreconf
-}
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" econf \
- $(use_enable combination-explosion-check) \
- $(use_enable crnl-as-line-terminator) \
- $(use_enable static-libs static)
-}
-
-multilib_src_install_all() {
- einstalldocs
- find "${D}" -name "*.la" -delete || die
-}