summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2024-01-26 21:13:38 +0100
committerFabian Groffen <grobian@gentoo.org>2024-01-26 21:13:38 +0100
commit607eb059494426721241e0edd9ab6a7b44278c6e (patch)
tree4902aece83585f824be039b579d9cdb738e7dbb9
parentapp-text/antiword: marked ~arm64 (diff)
downloadgentoo-607eb059494426721241e0edd9ab6a7b44278c6e.tar.gz
gentoo-607eb059494426721241e0edd9ab6a7b44278c6e.tar.bz2
gentoo-607eb059494426721241e0edd9ab6a7b44278c6e.zip
dev-util/uncrustify-0.78.1: version bump
Closes: https://bugs.gentoo.org/908270 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
-rw-r--r--dev-util/uncrustify/Manifest1
-rw-r--r--dev-util/uncrustify/uncrustify-0.78.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/uncrustify/Manifest b/dev-util/uncrustify/Manifest
index 4fbf784d45b8..4e7b395a8158 100644
--- a/dev-util/uncrustify/Manifest
+++ b/dev-util/uncrustify/Manifest
@@ -1 +1,2 @@
DIST uncrustify-0.76.0.tar.gz 1653093 BLAKE2B 4054341aefebdd40fa5b20502e26603d2ca5cb43fe493c5aa9f1e86753bc8becf7733aa36a8c9348010c5a697a353fc67c73e5690beb51067eb7671749f314d6 SHA512 2d0f4dcca091890d3c384b2253b87dd51dba264b289890cc0dd39eff307d9f4069638be0493a8814d3e03a58c10dd1dc40bee5afd342ce28cccbc45bb61e9ed9
+DIST uncrustify-0.78.1.tar.gz 1733516 BLAKE2B b799e40763fa72dfed503e322556b35ff98b060e3f961d4acd7e69b5c240c629f78f4107dcd7132312b68c5aa0790ffcb2c7cf469965e7faeb5137afc5625164 SHA512 51ebbc8b08212adea76565cdb578ceb9435769066d70ac14b55fbf0d66bcb34bfcc1cedd9c14c7bafe7b75be8795b3b59a076e40bbad9d242cb06ee9c0ac8638
diff --git a/dev-util/uncrustify/uncrustify-0.78.1.ebuild b/dev-util/uncrustify/uncrustify-0.78.1.ebuild
new file mode 100644
index 000000000000..5b681b1ddc92
--- /dev/null
+++ b/dev-util/uncrustify/uncrustify-0.78.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+ scm_eclass=git-r3
+else
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
+ S=${WORKDIR}/${PN}-${P}
+fi
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit cmake python-any-r1 ${scm_eclass}
+
+DESCRIPTION="C/C++/C#/D/Java/Pawn code indenter and beautifier"
+HOMEPAGE="http://uncrustify.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}