summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Laurantin <olivier.laurantin@laposte.net>2019-10-05 10:06:47 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-10-07 08:19:44 +0300
commit608bc1e7e328ef199cd75a0f5a066aa49ad71587 (patch)
treec4842b0c2c26daee8e5b2c6cf12ecc277ffcea44
parentnet-mail/dot-forward: add back missing dependency (diff)
downloadgentoo-608bc1e7e328ef199cd75a0f5a066aa49ad71587.tar.gz
gentoo-608bc1e7e328ef199cd75a0f5a066aa49ad71587.tar.bz2
gentoo-608bc1e7e328ef199cd75a0f5a066aa49ad71587.zip
net-wireless/blueberry: version bump
Update to the latest upstream version Closes: https://bugs.gentoo.org/696196 Signed-off-by: Olivier Laurantin <olivier.laurantin@laposte.net> Package-Manager: Portage-2.3.76, Repoman-2.3.17 Closes: https://github.com/gentoo/gentoo/pull/13148 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--net-wireless/blueberry/Manifest1
-rw-r--r--net-wireless/blueberry/blueberry-1.2.9.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/net-wireless/blueberry/Manifest b/net-wireless/blueberry/Manifest
index d9de28b7be6c..68ed29c2618b 100644
--- a/net-wireless/blueberry/Manifest
+++ b/net-wireless/blueberry/Manifest
@@ -1 +1,2 @@
DIST blueberry-1.1.13.tar.gz 1382261 BLAKE2B 5b23429243bc63d864f7176139a577cb5c8aea1f00906c218c66e92b9d679ad793f6429d01f9e49f960674b1ad5100d642075a730db49dd568282ea00089d8a3 SHA512 587165b33f087720f9ae72dfb37feda9c6c3e4c4ad166a5a410c078a63bea0d33182b781f8f0c7840575917d06faec752866009c9b3664241b7ca23ab1586b94
+DIST blueberry-1.2.9.tar.gz 1402410 BLAKE2B 0b816d4ca812b18e00a88d0d5b9cd1d44086a29f656d56cb23eede9b7f5cf7380ecf802ebc04369d39cbff56912292bff10bf31724389ab4a33731d2ce61c822 SHA512 6119cc9a7e1c18db2110f568f9fc8717ff0cc1db5fa8794f95734229cc4ebbc658b9b19c9b545dabdcbfa56c4fe2c5631c5fe2e8675860645790bb1c67aaa8f6
diff --git a/net-wireless/blueberry/blueberry-1.2.9.ebuild b/net-wireless/blueberry/blueberry-1.2.9.ebuild
new file mode 100644
index 000000000000..8bcaa8254cf0
--- /dev/null
+++ b/net-wireless/blueberry/blueberry-1.2.9.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit eutils gnome2-utils python-single-r1 xdg-utils
+
+DESCRIPTION="A Bluetooth configuration tool"
+HOMEPAGE="https://github.com/linuxmint/blueberry"
+SRC_URI="https://github.com/linuxmint/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ >=net-wireless/gnome-bluetooth-3.14[introspection]
+ net-wireless/bluez[obex]
+ net-wireless/bluez-tools
+ || (
+ >=sys-apps/util-linux-2.31_rc1
+ net-wireless/rfkill
+ )
+ x11-libs/libnotify[introspection]
+ x11-misc/wmctrl"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ doins -r etc
+ exeinto /usr/bin
+ doexe usr/bin/*
+ exeinto /usr/lib/blueberry
+ doexe usr/lib/blueberry/*
+ insinto /usr
+ doins -r usr/share
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}