summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-09-25 14:35:07 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-09-25 22:36:55 +0200
commit609542aaf6dc6ea2448768bbf974ba48b110bf46 (patch)
tree50e401b0f6066a091def8e66225f449e42eb5fa7
parentgames-emulation/ppsspp: drop old 1.16.3 (diff)
downloadgentoo-609542aaf6dc6ea2448768bbf974ba48b110bf46.tar.gz
gentoo-609542aaf6dc6ea2448768bbf974ba48b110bf46.tar.bz2
gentoo-609542aaf6dc6ea2448768bbf974ba48b110bf46.zip
games-emulation/ppsspp: drop old 1.16.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--games-emulation/ppsspp/Manifest1
-rw-r--r--games-emulation/ppsspp/ppsspp-1.16.2.ebuild75
2 files changed, 0 insertions, 76 deletions
diff --git a/games-emulation/ppsspp/Manifest b/games-emulation/ppsspp/Manifest
index f975b2e14274..ed30d9e1197e 100644
--- a/games-emulation/ppsspp/Manifest
+++ b/games-emulation/ppsspp/Manifest
@@ -1,4 +1,3 @@
DIST ppsspp-1.15.4.tar.xz 51947468 BLAKE2B c6a5e621b02556b791ec41389f17dede63811c87ff628b8f1304ac950071b365ecc9be05f4042e4e3b81e77f5a14b6931577f08b0174fec821350a1d7eca4d6a SHA512 9d2c140b0d633e5ca6191aaf276b7e4f6d029f29d1313a45fb78ee3879fec09f57d816604c51474ab6fe9cde713787d5769e87466d3c3015fe6a9b195ff198d2
-DIST ppsspp-1.16.2.tar.xz 51098300 BLAKE2B 48c3981a3b3f732281afe52140df25ed2c061ecc72fe88638f4c5854a447bc1a5a659272fa87d15d2174b6dc8164c226844dc1e2de4cd2088f0f9c423695e768 SHA512 ab3834651385e4f8a4728b27e7772da6a3821d96aa10ece9e15de1db3a7825bbf104aa1f5846de6f14c4b284db8d56d4757e77c4545305b300d1c296a2845f40
DIST ppsspp-1.16.4.tar.xz 51110488 BLAKE2B 061090bfd646b0839de7aed8e4b249ac86353c8742cd293c8df5ffc0d93a67f960ff4836bc13b534ba34871719cea2dc485b7d14deaa17aa5ff3dd6f8663687e SHA512 6364bb821a456409c9ee20eb589d761aef02d7756063bd5faa035b856ca551db0675a65767a9ad09dc8eba5fda6ede8ea3eb384b6770570bd4925e11b8c05ac5
DIST ppsspp-1.16.tar.xz 50656132 BLAKE2B 5149bd859134a76a191e0f144bdcefc4c521276ebb1390fe5e24eeeb1227b77bab0458a760f29aed5ba169d566f12d5226f2b50a19e44172f1ad98c4eb8f400f SHA512 d65a8c9fb5d7ff45a99f5852d1071029bc51c1e8bdb45b3e78d961a46587553db4465bbd97b301db54a94b60772359929524047f08de3067cd3336f5f7717826
diff --git a/games-emulation/ppsspp/ppsspp-1.16.2.ebuild b/games-emulation/ppsspp/ppsspp-1.16.2.ebuild
deleted file mode 100644
index 6093ddbdd308..000000000000
--- a/games-emulation/ppsspp/ppsspp-1.16.2.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit python-any-r1 xdg cmake
-
-DESCRIPTION="A PSP emulator written in C++"
-HOMEPAGE="https://www.ppsspp.org/
- https://github.com/hrydgard/ppsspp/"
-
-if [[ ${PV} == *9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/hrydgard/${PN}.git"
-else
- SRC_URI="https://github.com/hrydgard/${PN}/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="Apache-2.0 BSD BSD-2 GPL-2 JSON MIT"
-SLOT="0"
-IUSE="discord qt5"
-RESTRICT="test"
-
-RDEPEND="
- app-arch/snappy:=
- app-arch/zstd:=
- dev-libs/libzip:=
- media-libs/glew:=
- media-libs/libpng:=
- media-libs/libsdl2[joystick]
- media-video/ffmpeg:0/56.58.58
- sys-libs/zlib:=
- virtual/opengl
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5[-gles2-only]
- dev-qt/qtmultimedia:5[-gles2-only]
- dev-qt/qtopengl:5[-gles2-only]
- dev-qt/qtwidgets:5[-gles2-only]
- )
- !qt5? ( media-libs/libsdl2[X,opengl,sound,video] )
-"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="
- ${PYTHON_DEPS}
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-CMakeLists-flags.patch
- "${FILESDIR}"/${PN}-disable-ccache-autodetection.patch
-)
-
-pkg_setup() {
- python-any-r1_pkg_setup
-}
-
-src_configure() {
- local -a mycmakeargs=(
- -DBUILD_SHARED_LIBS=OFF
- -DCMAKE_SKIP_RPATH=ON
- -DHEADLESS=false
- -DUSE_SYSTEM_FFMPEG=ON
- -DUSE_SYSTEM_LIBZIP=ON
- -DUSE_SYSTEM_SNAPPY=ON
- -DUSE_SYSTEM_ZSTD=ON
- -DUSE_DISCORD=$(usex discord)
- -DUSING_QT_UI=$(usex qt5)
- )
- cmake_src_configure
-}