summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-05-06 09:08:05 -0700
committerMatt Turner <mattst88@gentoo.org>2022-05-06 10:59:13 -0700
commit60bc7025606aa2dc4ae7ef342060507d80038eac (patch)
tree85ac6707d6258dae439b161f2ab674b81337a90d
parentwww-client/chromium: fix cross-compile for ppc64/x86 (diff)
downloadgentoo-60bc7025.tar.gz
gentoo-60bc7025.tar.bz2
gentoo-60bc7025.zip
net-dialup/freeradius: Fix typo in ebuild
It should be -shared and not --shared and this typo causes the build to fail with slibtool. Additionally it needs slibtool-shared and not rlibtool. Bug: https://bugs.gentoo.org/786102 Closes: https://github.com/gentoo/gentoo/pull/25351 Signed-off-by: orbea <orbea@riseup.net> Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--net-dialup/freeradius/freeradius-3.0.25-r2.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/net-dialup/freeradius/freeradius-3.0.25-r2.ebuild b/net-dialup/freeradius/freeradius-3.0.25-r2.ebuild
index 1577a0e55c8a..050f03a07fe2 100644
--- a/net-dialup/freeradius/freeradius-3.0.25-r2.ebuild
+++ b/net-dialup/freeradius/freeradius-3.0.25-r2.ebuild
@@ -129,15 +129,15 @@ src_prepare() {
raddb/radiusd.conf.in || die
# verbosity
- # build shared libraries using jlibtool --shared
+ # build shared libraries using jlibtool -shared
sed -i \
-e '/$(LIBTOOL)/s|--quiet ||g' \
- -e 's:--mode=\(compile\|link\):& --shared:g' \
+ -e 's:--mode=\(compile\|link\):& -shared:g' \
Make.inc.in || die
sed -i \
-e 's|--silent ||g' \
- -e 's:--mode=\(compile\|link\):& --shared:g' \
+ -e 's:--mode=\(compile\|link\):& -shared:g' \
scripts/libtool.mk || die
# crude measure to stop jlibtool from running ranlib and ar