summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-15 16:18:41 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-15 16:18:41 +0200
commit60c1d43adfa2a17196ea83933e05415b33915465 (patch)
tree9721a87b48a7ef712eb1e8733ab0721bebe2e5cd
parentdev-lang/python: Remove 3.13.0_alpha6 (diff)
downloadgentoo-60c1d43adfa2a17196ea83933e05415b33915465.tar.gz
gentoo-60c1d43adfa2a17196ea83933e05415b33915465.tar.bz2
gentoo-60c1d43adfa2a17196ea83933e05415b33915465.zip
dev-lang/python: Add a warning for experimental flags
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-lang/python/python-3.13.0_beta1_p1.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-lang/python/python-3.13.0_beta1_p1.ebuild b/dev-lang/python/python-3.13.0_beta1_p1.ebuild
index 7226cd952199..07234f97460a 100644
--- a/dev-lang/python/python-3.13.0_beta1_p1.ebuild
+++ b/dev-lang/python/python-3.13.0_beta1_p1.ebuild
@@ -117,6 +117,14 @@ QA_CONFIG_IMPL_DECL_SKIP=( chflags lchflags )
pkg_pretend() {
use test && check-reqs_pkg_pretend
+
+ if ! use gil || use jit; then
+ ewarn "USE=-gil and USE=jit flags are considered experimental upstream. Using"
+ ewarn "them could lead to unexpected breakage, including race conditions"
+ ewarn "and crashes, respectively. Please do not file Gentoo bugs, unless"
+ ewarn "you can reproduce the problem with dev-lang/python[gil,-jit]. Instead,"
+ ewarn "please consider reporting freethreading / JIT problems upstream."
+ fi
}
pkg_setup() {