summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2019-04-03 03:14:23 +0200
committerDavide Pesavento <pesa@gentoo.org>2019-04-03 03:14:23 +0200
commit60deb392bb7477ec998b8b6cd29063063e3eab1b (patch)
treefbdb493a57182f9540780f7ebe812ac72c0d107b
parentdev-python/PyQtWebEngine: new package (diff)
downloadgentoo-60deb392bb7477ec998b8b6cd29063063e3eab1b.tar.gz
gentoo-60deb392bb7477ec998b8b6cd29063063e3eab1b.tar.bz2
gentoo-60deb392bb7477ec998b8b6cd29063063e3eab1b.zip
x11-libs/qscintilla: use the new canonical SRC_URI
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
-rw-r--r--x11-libs/qscintilla/qscintilla-2.11.1.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/x11-libs/qscintilla/qscintilla-2.11.1.ebuild b/x11-libs/qscintilla/qscintilla-2.11.1.ebuild
index 548fa9681dc1..ae3d709bc0df 100644
--- a/x11-libs/qscintilla/qscintilla-2.11.1.ebuild
+++ b/x11-libs/qscintilla/qscintilla-2.11.1.ebuild
@@ -5,25 +5,30 @@ EAPI=7
inherit flag-o-matic qmake-utils
-MY_P=QScintilla_gpl-${PV/_pre/.dev}
-
DESCRIPTION="Qt port of Neil Hodgson's Scintilla C++ editor control"
HOMEPAGE="https://www.riverbankcomputing.com/software/qscintilla/intro"
-SRC_URI="https://www.riverbankcomputing.com/static/Downloads/QScintilla/${MY_P}.tar.gz"
+
+MY_PN=QScintilla
+MY_P=${MY_PN}_gpl-${PV/_pre/.dev}
+if [[ ${PV} == *_pre* ]]; then
+ SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
+else
+ SRC_URI="https://www.riverbankcomputing.com/static/Downloads/${MY_PN}/${PV}/${MY_P}.tar.gz"
+fi
LICENSE="GPL-3"
SLOT="0/15"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
IUSE="designer doc"
-DEPEND="
+RDEPEND="
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtprintsupport:5
dev-qt/qtwidgets:5
designer? ( dev-qt/designer:5 )
"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}"
S=${WORKDIR}/${MY_P}