summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-12-27 17:45:40 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2015-12-27 17:46:04 +0100
commit60df482e26eb1680148f79d7f5c7db2fdde6fa93 (patch)
treeb385a4f74d2673de1b2b7c04c33be97b5a5481f2
parentMerge branch 'SoapZaNet-bug-568438' (diff)
downloadgentoo-60df482e.tar.gz
gentoo-60df482e.tar.bz2
gentoo-60df482e.zip
dev-python/gst-python: version bump to 1.6.2
Drop dependency on libxml2 (nowhere to be found) and add missing introspection USE-dependencies for libraries that this package provides overrides for. Package-Manager: portage-2.2.26
-rw-r--r--dev-python/gst-python/Manifest1
-rw-r--r--dev-python/gst-python/gst-python-1.6.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/gst-python/Manifest b/dev-python/gst-python/Manifest
index cac62665c17a..d7c5378882ed 100644
--- a/dev-python/gst-python/Manifest
+++ b/dev-python/gst-python/Manifest
@@ -3,3 +3,4 @@ DIST gst-python-1.2.1.tar.bz2 410887 SHA256 8823e5a9ffc51212df412652da44dc3f2a0e
DIST gst-python-1.4.0.tar.xz 350316 SHA256 b1e40c29ceb41b03f08d38aca6056054f0341d0706276326dceeec6ac8d53d3e SHA512 b970fd16a3b9d82f343fbf20642d165bff25fb815cfe20cc51db8c04c298a8fbd9b96f41811c2d26982eadf1f9a84495c70fbdad553778c68604f828e4773a94 WHIRLPOOL 248d91fc0aac1314c4f7b40866579601a8024c947a29a90b5b6c3585358984f1a50eb6d56aec26609d37fc9144fdf38d5edd7ad61364481d25b7cebfaeff1a96
DIST gst-python-1.6.0.tar.xz 368100 SHA256 60dbc7f5ac2b6655ed4a7ed2cee63ee5a525d37cb16eaa6b9df7d7dfe4e9605f SHA512 6ca7e274d6aac580aec52d2bc635ffcd1361de73324a2818632d5304d59b71111433f888d89864ee2053ddd71cddec93a1f8dfe511414bd6e3ab2f26e87bfece WHIRLPOOL ef2c990a7949fc9e39b93761f817bba195fc53f314017a7223504930913fe883a6953aa1a3bdb7f1ebd2fef110b3bc2ec6e6e53108ae96125ea8f74a0cfa23e7
DIST gst-python-1.6.1.tar.xz 358396 SHA256 3cbe332e18fd2eaf23ddeee96c414f79ac1edc2f7d990582fa0ec5f977bd04f1 SHA512 f2df05ac3a9c4160eb785e2e750ceacdc2aaa4cef8571137d06495abbfe51a2607cfa6c66cd2722c0572153b2926bdbabcd6ddd652b99078007e02cb779eb1bc WHIRLPOOL 97b7bc4377280a96fcea38df9199389e36ef8f5782596f49101ae1e4221e9d49310c461f8e51f9e0e7f2c6aaf57d5bf5f45e783997f1b80e5b52ccf95dd499a0
+DIST gst-python-1.6.2.tar.xz 358316 SHA256 4e763e317079f48a2d6f37bd600bc19650d61597fac9f5763dbad293f72f9125 SHA512 1793a4853aee560e32a9a29553c2730a20ee140bd241f89eb8cb16407a1ea3296ff47d21304f801b3fca140cafb1b6dd2c3574d11e851c424206cad6d3dc750e WHIRLPOOL 160c5989f9d492c41b1208600d7fb524f5ca2fb126e00f648c31328863791b990f0335b74a53f0c41a8ed8352e4ac26f19a3b99f24b0c6295e5c9257b4b89a68
diff --git a/dev-python/gst-python/gst-python-1.6.2.ebuild b/dev-python/gst-python/gst-python-1.6.2.ebuild
new file mode 100644
index 000000000000..880e55289764
--- /dev/null
+++ b/dev-python/gst-python/gst-python-1.6.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 python{3_3,3_4,3_5} )
+
+inherit python-r1
+
+DESCRIPTION="A Python Interface to GStreamer"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}]
+ >=media-libs/gstreamer-${PV}:1.0[introspection]
+ >=media-libs/gst-plugins-base-${PV}:1.0[introspection]
+"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+"
+# XXX: unittests are not ported to 1.0 yet.
+
+src_prepare() {
+ prepare_gst() {
+ mkdir -p "${BUILD_DIR}" || die
+ }
+ python_foreach_impl prepare_gst
+}
+
+src_configure() {
+ ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir econf
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ python_foreach_impl run_in_build_dir default
+ prune_libtool_files --modules
+ einstalldocs
+}