summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-09 10:49:25 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-11 13:27:38 +0100
commit60fa952af8a8fd939091482881c81504e22f6b1a (patch)
tree6a5803ac97ca6794e2707627d94258fa63244644
parentkde-frameworks/kdav: drop 5.74.0* (diff)
downloadgentoo-60fa952af8a8fd939091482881c81504e22f6b1a.tar.gz
gentoo-60fa952af8a8fd939091482881c81504e22f6b1a.tar.bz2
gentoo-60fa952af8a8fd939091482881c81504e22f6b1a.zip
kde-frameworks/kdeclarative: drop 5.74.0*
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-frameworks/kdeclarative/Manifest1
-rw-r--r--kde-frameworks/kdeclarative/files/kdeclarative-5.74.0-block-shortcuts-when-recording-key-sequences.patch104
-rw-r--r--kde-frameworks/kdeclarative/kdeclarative-5.74.0-r2.ebuild38
3 files changed, 0 insertions, 143 deletions
diff --git a/kde-frameworks/kdeclarative/Manifest b/kde-frameworks/kdeclarative/Manifest
index 98f69e6ea38e..620dcc3e02d8 100644
--- a/kde-frameworks/kdeclarative/Manifest
+++ b/kde-frameworks/kdeclarative/Manifest
@@ -1,3 +1,2 @@
-DIST kdeclarative-5.74.0.tar.xz 190360 BLAKE2B cf4ac587189c4f6fba6a13eaea4eea95e7e8aacf902c8ed809fac03f5ca76c9e42eff9fa74c1dfb0d0618c71bd4109a1c6b8f6964b242659757efadcc149ddb5 SHA512 8428a60146275dff201518764678bb7c5acce473bcfa584ea1b4924db485ade1b45e55f3aa758fbcf326b15e0e24dcb0913fbabbedd795b7b47e3b3f7e897f78
DIST kdeclarative-5.77.0.tar.xz 185036 BLAKE2B 53ce685df457d3e8b33d37efedbd7ba56b430a228c32673ca01cdf401f80a8e3518431d15182dbf28f4fa4a439369e380e65c13cf9fe385f42c98d54d50043a6 SHA512 188dbb2ba5080b2b5cb9815686c0bc619921390389e2865330c6183c3cf0c6f0df6bba7009f9215f2c99759322bf1ed4cae68df5c696fd1c3ecaecbaf327419c
DIST kdeclarative-5.78.0.tar.xz 185136 BLAKE2B ef206cc43cfa24542ddf1168b3331d3cb7c589c17554501f7a09e1cf526d3afa8ce5eafbc3a932081b743b9fb461e8c5915ec9e3b3bc742253f77f33274b0c6c SHA512 cb98f7041f93c8a21da74a6bcaf463fdd257aa96a5495200c749d60d517817c6d9be2b58e99b0a8e23996861ed9dcd9043da1643062ac94755070fb1d2b13add
diff --git a/kde-frameworks/kdeclarative/files/kdeclarative-5.74.0-block-shortcuts-when-recording-key-sequences.patch b/kde-frameworks/kdeclarative/files/kdeclarative-5.74.0-block-shortcuts-when-recording-key-sequences.patch
deleted file mode 100644
index 66808f910bf0..000000000000
--- a/kde-frameworks/kdeclarative/files/kdeclarative-5.74.0-block-shortcuts-when-recording-key-sequences.patch
+++ /dev/null
@@ -1,104 +0,0 @@
-From 88aabf069a0e454777c15227126732a04c8cb8b2 Mon Sep 17 00:00:00 2001
-From: David Edmundson <kde@davidedmundson.co.uk>
-Date: Fri, 18 Sep 2020 00:13:07 +0100
-Subject: [PATCH] Block shortcuts when recording key sequences
-
-Otherwise you can't select alt+a as a shortcut without triggering the
-nmenomic generated shortcut on the "add application" button.
-
-Testing done:
-- clicked "Add custom shortcut", pressed alt+a, it was recorded
-successfully
-
-- focussed "Add custom shortcut", pressed alt+a, the relevant shortcut
-activated
-
-Note that isRecording was already declared, but not defined, which is
-why it looks like my diff misses something.
-
-BUG: 425979
----
- src/qmlcontrols/kquickcontrols/KeySequenceItem.qml | 7 +++++++
- .../kquickcontrols/private/keysequencehelper.cpp | 8 +++++++-
- .../kquickcontrols/private/keysequencehelper.h | 7 +++++++
- 3 files changed, 21 insertions(+), 1 deletion(-)
-
-diff --git a/src/qmlcontrols/kquickcontrols/KeySequenceItem.qml b/src/qmlcontrols/kquickcontrols/KeySequenceItem.qml
-index 9d8e035..d1fbc02 100644
---- a/src/qmlcontrols/kquickcontrols/KeySequenceItem.qml
-+++ b/src/qmlcontrols/kquickcontrols/KeySequenceItem.qml
-@@ -83,6 +83,13 @@ RowLayout {
- }
- }
-
-+ Keys.onShortcutOverride: {
-+ if (_helper.isRecording) {
-+ _helper.keyPressed(event.key, event.modifiers);
-+ event.accepted = true;
-+ }
-+ }
-+
- Keys.onPressed: {
- _helper.keyPressed(event.key, event.modifiers);
- event.accepted = true;
-diff --git a/src/qmlcontrols/kquickcontrols/private/keysequencehelper.cpp b/src/qmlcontrols/kquickcontrols/private/keysequencehelper.cpp
-index ba7ce01..26b0331 100644
---- a/src/qmlcontrols/kquickcontrols/private/keysequencehelper.cpp
-+++ b/src/qmlcontrols/kquickcontrols/private/keysequencehelper.cpp
-@@ -237,7 +237,10 @@ void KeySequenceHelper::setCheckAgainstShortcutTypes(KeySequenceHelper::Shortcut
- Q_EMIT checkAgainstShortcutTypesChanged();
- }
-
--
-+bool KeySequenceHelper::isRecording() const
-+{
-+ return d->isRecording;
-+}
-
- void KeySequenceHelper::clearKeySequence()
- {
-@@ -251,6 +254,7 @@ void KeySequenceHelperPrivate::startRecording()
- oldKeySequence = keySequence;
- keySequence = QKeySequence();
- isRecording = true;
-+ emit q->isRecordingChanged();
- grabbedWindow = QQuickRenderControl::renderWindowFor(q->window());
- if (!grabbedWindow) {
- grabbedWindow = q->window();
-@@ -265,6 +269,8 @@ void KeySequenceHelper::doneRecording()
- {
- d->modifierlessTimeout.stop();
- d->isRecording = false;
-+ emit isRecordingChanged();
-+
- d->stealActions.clear();
- if (d->grabbedWindow) {
- d->grabbedWindow->setKeyboardGrabEnabled(false);
-diff --git a/src/qmlcontrols/kquickcontrols/private/keysequencehelper.h b/src/qmlcontrols/kquickcontrols/private/keysequencehelper.h
-index c9068e8..daeedc5 100644
---- a/src/qmlcontrols/kquickcontrols/private/keysequencehelper.h
-+++ b/src/qmlcontrols/kquickcontrols/private/keysequencehelper.h
-@@ -51,6 +51,12 @@ class KeySequenceHelper : public QQuickItem
- NOTIFY checkAgainstShortcutTypesChanged
- )
-
-+ Q_PROPERTY(
-+ bool isRecording
-+ READ isRecording
-+ NOTIFY isRecordingChanged
-+ )
-+
- public:
-
- enum ShortcutType {
-@@ -116,6 +122,7 @@ Q_SIGNALS:
- void shortcutDisplayChanged(const QString &string);
- void captureFinished();
- void checkAgainstShortcutTypesChanged();
-+ void isRecordingChanged();
-
- public Q_SLOTS:
- void captureKeySequence();
---
-GitLab
-
diff --git a/kde-frameworks/kdeclarative/kdeclarative-5.74.0-r2.ebuild b/kde-frameworks/kdeclarative/kdeclarative-5.74.0-r2.ebuild
deleted file mode 100644
index f0a7eefaff7f..000000000000
--- a/kde-frameworks/kdeclarative/kdeclarative-5.74.0-r2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ECM_TEST="false"
-PVCUT=$(ver_cut 1-2)
-QTMIN=5.15.1
-inherit ecm kde.org
-
-DESCRIPTION="Framework providing integration of QML and KDE work spaces"
-LICENSE="LGPL-2+"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
-IUSE=""
-
-DEPEND="
- >=dev-qt/qtdeclarative-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtnetwork-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
- =kde-frameworks/kconfig-${PVCUT}*:5
- =kde-frameworks/kcoreaddons-${PVCUT}*:5
- =kde-frameworks/kglobalaccel-${PVCUT}*:5
- =kde-frameworks/ki18n-${PVCUT}*:5
- =kde-frameworks/kiconthemes-${PVCUT}*:5
- =kde-frameworks/kio-${PVCUT}*:5
- =kde-frameworks/knotifications-${PVCUT}*:5
- =kde-frameworks/kpackage-${PVCUT}*:5
- =kde-frameworks/kservice-${PVCUT}*:5
- =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
- =kde-frameworks/kwindowsystem-${PVCUT}*:5
- media-libs/libepoxy
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-block-shortcuts-when-recording-key-sequences.patch
-)