summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-13 10:49:33 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-13 12:54:37 +0100
commit60fd422149bd4406243f93e5b893943c1f4540cb (patch)
tree38e7e83494bcf820cb1b774ad406440612bcd772
parentdev-python/hypothesis: Bump to 6.0.1 (diff)
downloadgentoo-60fd422149bd4406243f93e5b893943c1f4540cb.tar.gz
gentoo-60fd422149bd4406243f93e5b893943c1f4540cb.tar.bz2
gentoo-60fd422149bd4406243f93e5b893943c1f4540cb.zip
dev-python/botocore: Bump to 1.19.53
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.19.53.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index e022a4edec31..e262e6f50b07 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,3 +4,4 @@ DIST botocore-1.19.43.tar.gz 7374325 BLAKE2B 7def5221bee4774a6b8a33e6499e499588f
DIST botocore-1.19.50.tar.gz 7382888 BLAKE2B 7de2ef7a7d051427191b13cdd47d3ebd9b4de505e3e17aa7dfb42de9a5eebffa2f06317a559631d219acc4380cc68c7dcfa1d6b0dc9cb123b2fa0315dd81df4e SHA512 7d1a8ff53e22fc265d8ac6492c0607f8948c9aa5862abaded93c605c3a3e4e98e535308e5ec1500a480636e03dbc3d849ec2b1dbf0efb22dffa841ce1cb551f9
DIST botocore-1.19.51.tar.gz 7385977 BLAKE2B 505dd818f001b11f248582ec0f24bb7aac2e0d9bd343670d23eeb7ec14420bb7b97835a737de9464ffe5d76a43d311feee0e19860b35fddfc8398da4d00739b3 SHA512 03209809f75a5916df03d312fb877a3e129a8677ebd4e7785bbf8311a55823fe6c8faa62c78908fe0d003dd1695e0593a961d73c98dec2a8a7260ce53d6603cf
DIST botocore-1.19.52.tar.gz 7386245 BLAKE2B 53e21b0c3e39bb3c7219e785b79a167e082f7de7a6c54b2c0e5c53f565c41f76042a9ccd1e2c7ae2e68e19ac2c43d9ce104f1ecfd6c606dead2533a319c969af SHA512 deb827631ffbed9980adc47f05e96d800dc2c65f67a156bbe29e3cd34e612169fc4169e173d06fb9fe42c92ddb1e5041dbd02ad838b80f82657b5bd851aa8fba
+DIST botocore-1.19.53.tar.gz 7387325 BLAKE2B 3432c9d71f7a021184c2ac99be9213015951d1bba445788dcb388a518b62a96a4d3871577d5e97f4f86f7b0830a009155667b05a960b1d06642599e3d4d484e4 SHA512 ffe1da3076e656c36f4c59c12fa9f466e63b6bbc0365f7ecb78a6dc6941eb3748d676188c2b0e5a2d23d21e5cb03daf2893aa04561e183dc931070fae77eea9f
diff --git a/dev-python/botocore/botocore-1.19.53.ebuild b/dev-python/botocore/botocore-1.19.53.ebuild
new file mode 100644
index 000000000000..fa25adc1c1ff
--- /dev/null
+++ b/dev-python/botocore/botocore-1.19.53.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}