summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-07 18:27:42 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-07 18:41:21 +0200
commit6100af5eaee3c5be9ef2af33ffc39e73cd2eca46 (patch)
treefc2d81d881df7e2b880e406f0688e41905da7c89
parentsys-devel/clang: Use the new version vars (diff)
downloadgentoo-6100af5eaee3c5be9ef2af33ffc39e73cd2eca46.tar.gz
gentoo-6100af5eaee3c5be9ef2af33ffc39e73cd2eca46.tar.bz2
gentoo-6100af5eaee3c5be9ef2af33ffc39e73cd2eca46.zip
dev-python/clang-python: Use the new version vars
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/clang-python/clang-python-15.0.2.9999.ebuild4
-rw-r--r--dev-python/clang-python/clang-python-16.0.0.9999.ebuild4
-rw-r--r--dev-python/clang-python/clang-python-16.0.0_pre20221006.ebuild4
3 files changed, 6 insertions, 6 deletions
diff --git a/dev-python/clang-python/clang-python-15.0.2.9999.ebuild b/dev-python/clang-python/clang-python-15.0.2.9999.ebuild
index f0290ca4c7b1..9b34adc8ac6f 100644
--- a/dev-python/clang-python/clang-python-15.0.2.9999.ebuild
+++ b/dev-python/clang-python/clang-python-15.0.2.9999.ebuild
@@ -30,7 +30,7 @@ RDEPEND="
BDEPEND="
${PYTHON_DEPS}
test? (
- sys-devel/clang:${PV%%.*}
+ sys-devel/clang:${LLVM_MAJOR}
)
"
@@ -40,7 +40,7 @@ llvm.org_set_globals
python_test() {
# tests rely on results from a specific clang version, so override
# the search path
- local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${PV%%.*}/$(get_libdir)
+ local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${LLVM_MAJOR}/$(get_libdir)
"${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
}
diff --git a/dev-python/clang-python/clang-python-16.0.0.9999.ebuild b/dev-python/clang-python/clang-python-16.0.0.9999.ebuild
index f0290ca4c7b1..9b34adc8ac6f 100644
--- a/dev-python/clang-python/clang-python-16.0.0.9999.ebuild
+++ b/dev-python/clang-python/clang-python-16.0.0.9999.ebuild
@@ -30,7 +30,7 @@ RDEPEND="
BDEPEND="
${PYTHON_DEPS}
test? (
- sys-devel/clang:${PV%%.*}
+ sys-devel/clang:${LLVM_MAJOR}
)
"
@@ -40,7 +40,7 @@ llvm.org_set_globals
python_test() {
# tests rely on results from a specific clang version, so override
# the search path
- local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${PV%%.*}/$(get_libdir)
+ local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${LLVM_MAJOR}/$(get_libdir)
"${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
}
diff --git a/dev-python/clang-python/clang-python-16.0.0_pre20221006.ebuild b/dev-python/clang-python/clang-python-16.0.0_pre20221006.ebuild
index f0290ca4c7b1..9b34adc8ac6f 100644
--- a/dev-python/clang-python/clang-python-16.0.0_pre20221006.ebuild
+++ b/dev-python/clang-python/clang-python-16.0.0_pre20221006.ebuild
@@ -30,7 +30,7 @@ RDEPEND="
BDEPEND="
${PYTHON_DEPS}
test? (
- sys-devel/clang:${PV%%.*}
+ sys-devel/clang:${LLVM_MAJOR}
)
"
@@ -40,7 +40,7 @@ llvm.org_set_globals
python_test() {
# tests rely on results from a specific clang version, so override
# the search path
- local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${PV%%.*}/$(get_libdir)
+ local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${LLVM_MAJOR}/$(get_libdir)
"${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
}