summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-07-02 09:36:07 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-07-02 09:37:09 +0200
commit61019ed248a31c0a67d4d87e376e4aa889df930e (patch)
treef976b3a073312abe2b9525e01c1904d402d9530a
parentnet-mail/courier-imap: Fix systemd files (diff)
downloadgentoo-61019ed2.tar.gz
gentoo-61019ed2.tar.bz2
gentoo-61019ed2.zip
sys-apps/util-linux: move gen_usr_ldscript after python install again
Closes: https://bugs.gentoo.org/689116 Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--sys-apps/util-linux/util-linux-2.34-r1.ebuild (renamed from sys-apps/util-linux/util-linux-2.34.ebuild)8
-rw-r--r--sys-apps/util-linux/util-linux-9999.ebuild8
2 files changed, 8 insertions, 8 deletions
diff --git a/sys-apps/util-linux/util-linux-2.34.ebuild b/sys-apps/util-linux/util-linux-2.34-r1.ebuild
index efc59ae73575..b15e6ad1a438 100644
--- a/sys-apps/util-linux/util-linux-2.34.ebuild
+++ b/sys-apps/util-linux/util-linux-2.34-r1.ebuild
@@ -243,14 +243,14 @@ python_install() {
multilib_src_install() {
emake DESTDIR="${D}" install
+ if multilib_is_native_abi && use python; then
+ python_foreach_impl python_install
+ fi
+
if multilib_is_native_abi && use userland_GNU; then
# need the libs in /
gen_usr_ldscript -a blkid fdisk mount smartcols uuid
fi
-
- if multilib_is_native_abi && use python; then
- python_foreach_impl python_install
- fi
}
multilib_src_install_all() {
diff --git a/sys-apps/util-linux/util-linux-9999.ebuild b/sys-apps/util-linux/util-linux-9999.ebuild
index efc59ae73575..b15e6ad1a438 100644
--- a/sys-apps/util-linux/util-linux-9999.ebuild
+++ b/sys-apps/util-linux/util-linux-9999.ebuild
@@ -243,14 +243,14 @@ python_install() {
multilib_src_install() {
emake DESTDIR="${D}" install
+ if multilib_is_native_abi && use python; then
+ python_foreach_impl python_install
+ fi
+
if multilib_is_native_abi && use userland_GNU; then
# need the libs in /
gen_usr_ldscript -a blkid fdisk mount smartcols uuid
fi
-
- if multilib_is_native_abi && use python; then
- python_foreach_impl python_install
- fi
}
multilib_src_install_all() {