summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-27 23:45:59 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-28 17:26:42 +0200
commit6107303df0aa09672758cd9fd3cbc1be46b6f546 (patch)
treed704b1702e4879276ce4d6d6eb7704fbb2cb4b73
parentsys-kernel/gentoo-sources: Linux patch 4.9.171 (diff)
downloadgentoo-6107303d.tar.gz
gentoo-6107303d.tar.bz2
gentoo-6107303d.zip
dev-python/owslib: 0.17.1 version bump
Package-Manager: Portage-2.3.65, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-python/owslib/Manifest1
-rw-r--r--dev-python/owslib/owslib-0.17.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/owslib/Manifest b/dev-python/owslib/Manifest
index 54d45a8500a3..4bedfbb537ee 100644
--- a/dev-python/owslib/Manifest
+++ b/dev-python/owslib/Manifest
@@ -1 +1,2 @@
DIST owslib-0.16.0.tar.gz 658145 BLAKE2B 8e32de48192579f10515771c1682b1d1319deb8195ff9c0f9168ea82bb30bbc8bcf7c457c794a79b1121d40f3f544624f0a9789b0f6f36632c6457f396fa78c9 SHA512 a468352dfdb62bea1e6189efcc198237cb909051e51782abb15093e328ca7d3d379e88d0466e42c39ce9bc201a3be828a779193666bf9befe8d501355aaddbf4
+DIST owslib-0.17.1.tar.gz 898961 BLAKE2B e48b10a0bd9dc1e85588b8007261c47f9f754af9eeb7292d4a3fd9ce017309efbe0fc9951a42470a6938194e5903b12ffe286b140d906e1d281f5a2f739540ce SHA512 0772f7698d1d5c6989419a455e8b6d97b0fc9f04a48275b1179f5bcc0fe782620721e840969281941b0f0a3616d8220916090256bb177eff1b2a4df0e02e2caa
diff --git a/dev-python/owslib/owslib-0.17.1.ebuild b/dev-python/owslib/owslib-0.17.1.ebuild
new file mode 100644
index 000000000000..8fa38d39c553
--- /dev/null
+++ b/dev-python/owslib/owslib-0.17.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Library for client programming with Open Geospatial Consortium web service"
+HOMEPAGE="https://geopython.github.io/OWSLib"
+SRC_URI="https://github.com/geopython/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pyproj[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ || (
+ dev-python/elementtree[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+RESTRICT="test" # tests require WAN access
+
+S="${WORKDIR}/OWSLib-${PV}"
+
+python_test() {
+ "${EPYTHON}" "${S}/setup.py" test || die
+}