summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2022-10-19 10:40:28 +0200
committerAgostino Sarubbo <ago@gentoo.org>2022-10-19 10:40:28 +0200
commit6107896abba0b799694e1628fe061c9cb2776d00 (patch)
treec9f064046a0a74e660a98e92440024e8b754e804
parentmedia-libs/flac: Stabilize 1.4.1 ppc64, #875647 (diff)
downloadgentoo-6107896abba0b799694e1628fe061c9cb2776d00.tar.gz
gentoo-6107896abba0b799694e1628fe061c9cb2776d00.tar.bz2
gentoo-6107896abba0b799694e1628fe061c9cb2776d00.zip
app-admin/exo: version bump to 1.59.3
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
-rw-r--r--app-admin/exo/Manifest1
-rw-r--r--app-admin/exo/exo-1.59.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/exo/Manifest b/app-admin/exo/Manifest
index e460e75f9f41..d7b69ff26908 100644
--- a/app-admin/exo/Manifest
+++ b/app-admin/exo/Manifest
@@ -1 +1,2 @@
DIST exo-1.59.2.tar.gz 5614063 BLAKE2B 358b3fa7935c092e5942d2864b4f25a6d78689558fbd4d11b7bacab29a2d93907e21e098f45896a2f2bca923d6f2addcc5fd04aa2aed56826ca78184dcc0c724 SHA512 7e935ff794a6c7e3236a6f2557f5a9c1d2662e7333d137bbbb866d4d1b889dc07b604643ffebaf20da4fa97bfe09fc1e84f57159c38edc2e4ea902a51b7cf680
+DIST exo-1.59.3.tar.gz 5505533 BLAKE2B a49e7118f9c8b201a3baeeeb8735ada48bb541cd8be266bee9fc0e59825db00559869a29087bd20a711db5b3d1c91b6437119c1b5a49d9080044fef48b9ba836 SHA512 50146ad59c495235da44be5d7043ca45cba782b1a0a84e6f1ad3b85e1064c52e50d8696622d689a6e1b5f0e70b1f91e2a34aa5c9ba77a9b59e6552acb511282e
diff --git a/app-admin/exo/exo-1.59.3.ebuild b/app-admin/exo/exo-1.59.3.ebuild
new file mode 100644
index 000000000000..6149acedfa18
--- /dev/null
+++ b/app-admin/exo/exo-1.59.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command-line tool for everything at Exoscale: compute, storage, dns"
+HOMEPAGE="https://github.com/exoscale/cli"
+SRC_URI="https://github.com/exoscale/cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+DEPEND="dev-lang/go:="
+RESTRICT="strip"
+QA_FLAGS_IGNORED=".*"
+
+S="${WORKDIR}/cli-${PV}"
+
+src_compile() {
+ go build -mod vendor -o ${PN} || die "build failed"
+}
+
+src_test() {
+ # run at least 'exo version' for test
+ ./exo version > /dev/null 2>&1
+ if [[ $? -ne 0 ]]
+ then
+ die "Test failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+}