summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-04 17:02:49 +0100
committerSam James <sam@gentoo.org>2023-10-04 17:47:15 +0100
commit611739f6d355367906a758a61282ecce8ed82f7a (patch)
treed8c688d31843c513355970b07a6e2dca6b119261
parentapp-emulation/86Box: add 4.0 (diff)
downloadgentoo-611739f6d355367906a758a61282ecce8ed82f7a.tar.gz
gentoo-611739f6d355367906a758a61282ecce8ed82f7a.tar.bz2
gentoo-611739f6d355367906a758a61282ecce8ed82f7a.zip
app-crypt/pesign: add 116
Bug: https://bugs.gentoo.org/842228 Bug: https://bugs.gentoo.org/897706 Closes: https://bugs.gentoo.org/892932 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-crypt/pesign/Manifest1
-rw-r--r--app-crypt/pesign/files/pesign-116-no-werror.patch11
-rw-r--r--app-crypt/pesign/pesign-116.ebuild57
3 files changed, 69 insertions, 0 deletions
diff --git a/app-crypt/pesign/Manifest b/app-crypt/pesign/Manifest
index e3ca7ffe3ede..aaf05c8e4530 100644
--- a/app-crypt/pesign/Manifest
+++ b/app-crypt/pesign/Manifest
@@ -1 +1,2 @@
DIST pesign-114.tar.gz 148898 BLAKE2B 0dae3b4e17c61bcea02a6f81f6a62f8d526e83954bf95d0de24726daa81e45a3b42b6867f2d64decd69f421a14f5e2ff6ff1ec26246f44d68b242b452e60d9a1 SHA512 567176718e098c3494e27ce29b61ef396ca2503137260fc36c784951f0bd2130c9f61c655461d6091e9bdb0df77c9e00cf2fde8fb1b1c5ab83e4b9c57d65fdab
+DIST pesign-116.tar.bz2 120424 BLAKE2B a1bce804c13a0aba1eb5fdf0b3963d658011484d4708d58bd9265b6ad8a3d2d3e3156a49736e6fb029bd5d8cc175f6440e62dbc34722357888a239e4d7e7d9e2 SHA512 be3e1083f5e9f889cb8f7c50a8ebe723542fb2f6d1de8de9b04a9f21526ebaa8ab1efc7d4be11bcb0bc9862fa4bc6f78ee35e4d3496dd3b8927170b97795d25c
diff --git a/app-crypt/pesign/files/pesign-116-no-werror.patch b/app-crypt/pesign/files/pesign-116-no-werror.patch
new file mode 100644
index 000000000000..0563a749baf6
--- /dev/null
+++ b/app-crypt/pesign/files/pesign-116-no-werror.patch
@@ -0,0 +1,11 @@
+--- a/Make.defaults
++++ b/Make.defaults
+@@ -60,7 +60,7 @@ cflags = $(CFLAGS) $(ARCH3264) \
+ -Wall -Wextra -Wsign-compare -Wno-unused-result \
+ -Wno-unused-function -Wno-missing-field-initializers \
+ $(call enabled,ENABLE_LEAK_CHECKER,-Wno-analyzer-malloc-leak,) \
+- -Werror -Wno-error=cpp -Wno-free-nonheap-object \
++ -Wno-error=cpp -Wno-free-nonheap-object \
+ -std=gnu11 -fshort-wchar -fPIC -fno-strict-aliasing \
+ -D_GNU_SOURCE -DCONFIG_$(ARCH) -I${TOPDIR}/include \
+ '-DRUNDIR="$(rundir)"' \
diff --git a/app-crypt/pesign/pesign-116.ebuild b/app-crypt/pesign/pesign-116.ebuild
new file mode 100644
index 000000000000..d890d561aad2
--- /dev/null
+++ b/app-crypt/pesign/pesign-116.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tools for manipulating signed PE-COFF binaries"
+HOMEPAGE="https://github.com/rhboot/pesign"
+SRC_URI="https://github.com/rhboot/pesign/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/nspr
+ dev-libs/nss
+ dev-libs/openssl:=
+ dev-libs/popt
+ sys-apps/util-linux
+ >=sys-libs/efivar-38
+"
+DEPEND="
+ ${RDEPEND}
+ sys-boot/gnu-efi
+"
+BDEPEND="
+ sys-apps/help2man
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-116-no-werror.patch
+)
+
+src_compile() {
+ emake \
+ AR="$(tc-getAR)" \
+ ARFLAGS="-cvqs" \
+ AS="$(tc-getAS)" \
+ CC="$(tc-getCC)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ LD="$(tc-getLD)" \
+ OBJCOPY="$(tc-getOBJCOPY)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)" \
+ RANLIB="$(tc-getRANLIB)" \
+ rundir="${EPREFIX}/var/run"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" VERSION="${PVR}" rundir="${EPREFIX}/var/run" install
+ einstalldocs
+
+ # remove some files that don't make sense for Gentoo installs
+ rm -rf "${ED}/etc" "${ED}/var" "${ED}/usr/share/doc/${PF}/COPYING" || die
+}