summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMats Lidell <matsl@gentoo.org>2023-05-10 23:02:01 +0200
committerMats Lidell <matsl@gentoo.org>2023-05-10 23:09:42 +0200
commit61270ab31f594d9b8a697012ff99aece9f1c3a83 (patch)
tree532e4aa934d2fe10deeedb3e349e248e8c0f9a44
parentapp-emacs/elpa-mirror: new package; add 2.2.2 (diff)
downloadgentoo-61270ab31f594d9b8a697012ff99aece9f1c3a83.tar.gz
gentoo-61270ab31f594d9b8a697012ff99aece9f1c3a83.tar.bz2
gentoo-61270ab31f594d9b8a697012ff99aece9f1c3a83.zip
app-editors/xemacs: use freewnn with gcc-13
Closes: https://bugs.gentoo.org/905434 Signed-off-by: Mats Lidell <matsl@gentoo.org>
-rw-r--r--app-editors/xemacs/xemacs-21.4.24-r10.ebuild4
-rw-r--r--app-editors/xemacs/xemacs-21.5.34-r13.ebuild4
-rw-r--r--app-editors/xemacs/xemacs-21.5.9999.ebuild4
3 files changed, 9 insertions, 3 deletions
diff --git a/app-editors/xemacs/xemacs-21.4.24-r10.ebuild b/app-editors/xemacs/xemacs-21.4.24-r10.ebuild
index cf1b3d10906b..7d1252abe2f3 100644
--- a/app-editors/xemacs/xemacs-21.4.24-r10.ebuild
+++ b/app-editors/xemacs/xemacs-21.4.24-r10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# Note: xemacs currently does not work with position independent code
@@ -175,6 +175,8 @@ src_configure() {
# see bug 576512
append-cflags -fgnu89-inline
+ use freewnn && append-cppflags "-I. -I${ESYSROOT}/usr/include/wnn"
+
# Don't use econf because it uses options which this configure
# script does not understand (like --host).
./configure ${myconf} ${EXTRA_ECONF} \
diff --git a/app-editors/xemacs/xemacs-21.5.34-r13.ebuild b/app-editors/xemacs/xemacs-21.5.34-r13.ebuild
index d257f4c26662..51b3f8f5095c 100644
--- a/app-editors/xemacs/xemacs-21.5.34-r13.ebuild
+++ b/app-editors/xemacs/xemacs-21.5.34-r13.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# Note: xemacs currently does not work with position independent code
@@ -168,6 +168,8 @@ src_configure() {
use debug && myconf="${myconf} --with-debug" ||
myconf="${myconf} --with-optimization --with-cflags-debugging="
+ use freewnn && append-cppflags "-I. -I${ESYSROOT}/usr/include/wnn"
+
econf ${myconf} \
$(use_with gif ) \
$(use_with gpm ) \
diff --git a/app-editors/xemacs/xemacs-21.5.9999.ebuild b/app-editors/xemacs/xemacs-21.5.9999.ebuild
index c164858b40dd..f2e01acd2ca1 100644
--- a/app-editors/xemacs/xemacs-21.5.9999.ebuild
+++ b/app-editors/xemacs/xemacs-21.5.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# Note: xemacs currently does not work with position independent code
@@ -160,6 +160,8 @@ src_configure() {
use debug && myconf="${myconf} --with-debug" ||
myconf="${myconf} --with-optimization --with-cflags-debugging="
+ use freewnn && append-cppflags "-I. -I${ESYSROOT}/usr/include/wnn"
+
econf ${myconf} \
$(use_with gif ) \
$(use_with gpm ) \