summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-06-26 19:59:40 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-06-27 02:48:48 +0000
commit6149feae904630714491a01869a6db5f20baa723 (patch)
tree1aa065307424eddc946ebfdd03cccba16bc936f1
parentdev-python/aplpy: added python-3.6 (diff)
downloadgentoo-6149feae904630714491a01869a6db5f20baa723.tar.gz
gentoo-6149feae904630714491a01869a6db5f20baa723.tar.bz2
gentoo-6149feae904630714491a01869a6db5f20baa723.zip
dev-python/wcsaxes: added python-3.6, and matplotlib environment to avoid importing Tk
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--dev-python/wcsaxes/wcsaxes-0.9.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/wcsaxes/wcsaxes-0.9.ebuild b/dev-python/wcsaxes/wcsaxes-0.9.ebuild
index 9101ea4791bd..898e26934a0d 100644
--- a/dev-python/wcsaxes/wcsaxes-0.9.ebuild
+++ b/dev-python/wcsaxes/wcsaxes-0.9.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
inherit distutils-r1 virtualx xdg-utils
@@ -33,6 +33,8 @@ PATCHES=(
python_prepare_all() {
# use system astropy-helpers instead of bundled one
sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ echo "backend: Agg" > "${WORKDIR}"/matplotlibrc || die
+ export MATPLOTLIBRC="${WORKDIR}"
xdg_environment_reset
distutils-r1_python_prepare_all
}