summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-04-20 09:01:47 -0500
committerSebastian Pipping <sping@gentoo.org>2018-04-21 22:56:09 +0200
commit614ffb79e1bb969e77646f768d00bd0e02cf3647 (patch)
tree57d94e3e8222e192fc81858117f2cf656a97d665
parentdev-libs/expat: epatch->PATCHES=() (diff)
downloadgentoo-614ffb79.tar.gz
gentoo-614ffb79.tar.bz2
gentoo-614ffb79.zip
media-gfx/gimp: epatch->PATCHES=()
This one was a bit strange; just moving all the patches into a PATCHES=() array and calling default at the start of src_prepare() didn't do the trick, as apparently it was applying the patches twice. Apparently gnome2_src_configure calls xdg_src_configure, which calls default. Moving gnome2_src_configure to the start of src_prepare() worked. Due to how involved the change was, I gave this a full ebuild gimp-2.9.8-r1.ebuild clean install treatment instead of my standard clean prepare for these patch fixes. Package-Manager: Portage-2.3.31, Repoman-2.3.9
-rw-r--r--media-gfx/gimp/gimp-2.9.8-r1.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/media-gfx/gimp/gimp-2.9.8-r1.ebuild b/media-gfx/gimp/gimp-2.9.8-r1.ebuild
index fc1d80723b35..fd50f6600b1d 100644
--- a/media-gfx/gimp/gimp-2.9.8-r1.ebuild
+++ b/media-gfx/gimp/gimp-2.9.8-r1.ebuild
@@ -85,23 +85,23 @@ pkg_setup() {
fi
}
-src_prepare() {
- epatch "${FILESDIR}"/${P}-cve-2017-17784.patch # bug 641954
- epatch "${FILESDIR}"/${PN}-2.8.22-cve-2017-17785.patch # bug 641954
- epatch "${FILESDIR}"/${PN}-2.8.22-cve-2017-17786-1.patch # bug 641954
- epatch "${FILESDIR}"/${PN}-2.8.22-cve-2017-17786-2.patch # bug 641954
- epatch "${FILESDIR}"/${PN}-2.8.22-cve-2017-17787.patch # bug 641954
+PATCHES=(
+ "${FILESDIR}"/${P}-cve-2017-17784.patch # bug 641954
+ "${FILESDIR}"/${PN}-2.8.22-cve-2017-17785.patch # bug 641954
+ "${FILESDIR}"/${PN}-2.8.22-cve-2017-17786-1.patch # bug 641954
+ "${FILESDIR}"/${PN}-2.8.22-cve-2017-17786-2.patch # bug 641954
+ "${FILESDIR}"/${PN}-2.8.22-cve-2017-17787.patch # bug 641954
# NOTE: CVE-2017-17788 already fixed upstream
- epatch "${FILESDIR}"/${PN}-2.8.22-cve-2017-17789.patch # bug 641954
+ "${FILESDIR}"/${PN}-2.8.22-cve-2017-17789.patch # bug 641954
+)
- eapply_user
+src_prepare() {
+ gnome2_src_prepare
sed -i -e 's/== "xquartz"/= "xquartz"/' configure.ac || die #494864
sed 's:-DGIMP_DISABLE_DEPRECATED:-DGIMP_protect_DISABLE_DEPRECATED:g' -i configure.ac || die #615144
eautoreconf # If you remove this: remove dev-util/gtk-doc-am from DEPEND, too
- gnome2_src_prepare
-
sed 's:-DGIMP_protect_DISABLE_DEPRECATED:-DGIMP_DISABLE_DEPRECATED:g' -i configure || die #615144
fgrep -q GIMP_DISABLE_DEPRECATED configure || die #615144, self-test
}