summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-12-06 01:31:48 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-12-06 01:42:23 +0100
commit6151eac947887c80a686cce9cfc7e51a5c22597f (patch)
treea4e06fe25d37357e438b679059ed49a0d34fa251
parentdev-python/pythonutils: rescue dep of net-nntp/sabnzbd (diff)
downloadgentoo-6151eac9478.tar.gz
gentoo-6151eac9478.tar.bz2
gentoo-6151eac9478.zip
dev-python/sabyenc: bump to v3.3.6
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--dev-python/sabyenc/Manifest1
-rw-r--r--dev-python/sabyenc/sabyenc-3.3.6.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/sabyenc/Manifest b/dev-python/sabyenc/Manifest
index 581cf3ccf68d..46d9ebf9a9db 100644
--- a/dev-python/sabyenc/Manifest
+++ b/dev-python/sabyenc/Manifest
@@ -1 +1,2 @@
DIST sabyenc-3.3.5.tar.gz 19578318 BLAKE2B d36182074682a00cdca15be12d9d1424f9d3a8f03130df905e53814135cb0f685086d643ad23f3aec47b56b50b3ca43925a0fb4a3ded14cae2559fd14b6beeaf SHA512 94b5114be111feafc65f75d6461e5135bc1b8c8a84d8501f28e1035150d5581e901e7290f5b4cc6cb5426fac5d4971d138c43f6a62ec3bfe43ea9b5f269c0a89
+DIST sabyenc-3.3.6.tar.gz 19578544 BLAKE2B dc196618578b213fa8f1ffc2c29340d9f9765d98942c354ef7510a6472c4594431448291d19153b1f51606d27c4e43b34d12623ca69dc366aea3aa0483713489 SHA512 bc9a1d1cd487dc0a1a0cc8ef690cef67de70c211dce520896888c3d37167e83439002f4ab6cf0cef14a27b45b0ee08ad349d34e1609abb45f33e2f2f7b5ac074
diff --git a/dev-python/sabyenc/sabyenc-3.3.6.ebuild b/dev-python/sabyenc/sabyenc-3.3.6.ebuild
new file mode 100644
index 000000000000..cd21981df430
--- /dev/null
+++ b/dev-python/sabyenc/sabyenc-3.3.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Module providing raw yEnc encoding/decoding for SABnzbd"
+HOMEPAGE="https://github.com/sabnzbd/sabyenc/"
+SRC_URI="https://github.com/sabnzbd/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+DOCS=( CHANGES.md README.md doc/yenc-draft.1.3.txt )
+
+python_test() {
+ pytest -v || die "Test failed."
+}