summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-12-12 09:21:49 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-12-12 16:23:42 -0500
commit617789b9ec720d50ba58de438cc74898a8ec2028 (patch)
tree55a1fd43ea96435d5453168fce792e327c59512f
parentdev-qt/qtsvg: drop 6.6.0-r1 (diff)
downloadgentoo-617789b9ec720d50ba58de438cc74898a8ec2028.tar.gz
gentoo-617789b9ec720d50ba58de438cc74898a8ec2028.tar.bz2
gentoo-617789b9ec720d50ba58de438cc74898a8ec2028.zip
dev-qt/qttools: drop 6.6.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-qt/qttools/Manifest1
-rw-r--r--dev-qt/qttools/qttools-6.6.0.ebuild146
2 files changed, 0 insertions, 147 deletions
diff --git a/dev-qt/qttools/Manifest b/dev-qt/qttools/Manifest
index c92b4b16516d..fdf4bf178faa 100644
--- a/dev-qt/qttools/Manifest
+++ b/dev-qt/qttools/Manifest
@@ -1,3 +1,2 @@
DIST qttools-everywhere-src-6.5.3.tar.xz 8591996 BLAKE2B 072b0b49182fac824364e7ac71df5698009ce0e8f144422c752373e122c587f6bdb306c2bb605c39228d8d5a1c1e0a89c8d56daef5f3de1cbb66aeb53e036962 SHA512 7e383cdc575400d19051232dc563eaf330209605f28a93ac01f32921d0d966bc9a51bb5b56fb8f5c00ed4aab5fa2806b3bd0c8750aa2f49f5a04c85fa68fe30b
-DIST qttools-everywhere-src-6.6.0.tar.xz 8582212 BLAKE2B 01c3cd188574dd2140756372d2aefb6e2c2dab1b866d2a120afb2fa19eff1eeeb288ae9845b55736bc77e8fb8173b2badaca091c9a7aa745fb1f2a0d864d191a SHA512 42a5df24b57afc5d60d33d6e6dc4021b9c1dbaba2fb7cab251ab636df8457619ee55177d6fe3dd93db335f271a3b40a86a9f7a3c76e34373ed7bce449a9b0652
DIST qttools-everywhere-src-6.6.1.tar.xz 8583536 BLAKE2B c52fd1643f925909c2e5f677574ee202c0de5b810e9ca603f27511b123ce570c4bbf4aa3efd2c4347dace91d92546f5cb90e7ca783b7182369d13dcdbdac2db4 SHA512 7f7bfaf7f01a5374f711c20113e9461b83a6f908b48c7b3f662f8821a70ef0c792f040f2e8e62a570fec06df2329fe5eb953c680424262b3678ab283045e6909
diff --git a/dev-qt/qttools/qttools-6.6.0.ebuild b/dev-qt/qttools/qttools-6.6.0.ebuild
deleted file mode 100644
index 8966bdc9123b..000000000000
--- a/dev-qt/qttools/qttools-6.6.0.ebuild
+++ /dev/null
@@ -1,146 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit desktop llvm optfeature qt6-build
-
-DESCRIPTION="Qt Tools Collection"
-
-if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~x86"
-fi
-
-IUSE="
- +assistant clang designer distancefieldgenerator gles2-only
- +linguist opengl pixeltool qdbus qdoc qml qtattributionsscanner
- qtdiag qtplugininfo vulkan +widgets zstd
-"
-# note that some tools do not *require* widgets but will skip a sub-tool
-# if not enabled (e.g. linguist gives lrelease but not the GUI linguist6)
-REQUIRED_USE="
- assistant? ( widgets )
- designer? ( qml widgets )
- distancefieldgenerator? ( qml widgets )
- pixeltool? ( widgets )
- qdoc? ( clang qml )
-"
-
-# behaves very badly when qttools is not already installed, also
-# other more minor issues (clang tests flaky depending on version,
-# and 3rdparty/ tries to FetchContent gtest)
-RESTRICT="test"
-
-LLVM_MAX_SLOT=17
-RDEPEND="
- ~dev-qt/qtbase-${PV}:6[network,widgets?]
- assistant? ( ~dev-qt/qtbase-${PV}:6[sql,sqlite] )
- clang? ( <sys-devel/clang-$((LLVM_MAX_SLOT+1)):= )
- designer? (
- ~dev-qt/qtbase-${PV}:6[xml,zstd=]
- zstd? ( app-arch/zstd:= )
- )
- qdbus? ( ~dev-qt/qtbase-${PV}:6[dbus,xml] )
- qml? ( ~dev-qt/qtdeclarative-${PV}:6[widgets?] )
- qtdiag? ( ~dev-qt/qtbase-${PV}:6[gles2-only=,vulkan=] )
- widgets? ( ~dev-qt/qtbase-${PV}:6[opengl=] )
-"
-DEPEND="
- ${RDEPEND}
- qtdiag? (
- vulkan? ( dev-util/vulkan-headers )
- )
-"
-
-llvm_check_deps() {
- has_version -d "sys-devel/clang:${LLVM_SLOT}"
-}
-
-pkg_setup() {
- use clang && llvm_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- $(cmake_use_find_package qml Qt6Qml)
- $(cmake_use_find_package widgets Qt6Widgets)
- $(qt_feature assistant)
- $(qt_feature clang)
- $(qt_feature designer)
- $(qt_feature distancefieldgenerator)
- $(qt_feature linguist)
- $(qt_feature pixeltool)
- $(qt_feature qdbus)
- $(qt_feature qdoc)
- $(qt_feature qtattributionsscanner)
- $(qt_feature qtdiag)
- $(qt_feature qtplugininfo)
-
- # TODO?: package litehtml, but support for latest releases seem
- # to lag behind and bundled may work out better for now
- # https://github.com/litehtml/litehtml/issues/266
- $(usev assistant -DCMAKE_DISABLE_FIND_PACKAGE_litehtml=ON)
- )
-
- qt6-build_src_configure
-}
-
-src_install() {
- qt6-build_src_install
-
- if use widgets; then #914766
- use designer || use distancefieldgenerator || use pixeltool &&
- newicon src/designer/src/designer/images/designer.png designer6.png
-
- if use assistant; then
- make_desktop_entry assistant6 'Qt 6 Assistant' assistant6 \
- 'Qt;Development;Documentation' \
- 'Comment=Tool for viewing online documentation in Qt help file format'
- newicon src/assistant/assistant/images/assistant-128.png assistant6.png
- fi
-
- if use designer; then
- make_desktop_entry designer6 'Qt 6 Designer' designer6 \
- 'Qt;Development;GUIDesigner' \
- 'Comment=WYSIWYG tool for designing and building graphical user interfaces with QtWidgets'
- fi
-
- if use distancefieldgenerator; then
- # no icon, sharing with designer which fits letter-wise
- make_desktop_entry qdistancefieldgenerator6 'Qt 6 Distance Field Generator' designer6 \
- 'Qt;Development' \
- 'Comment=Tool for pregenerating the font cache of Qt applications'
- fi
-
- if use linguist; then
- make_desktop_entry linguist6 'Qt 6 Linguist' linguist6 \
- 'Qt;Development;Translation' \
- 'Comment=Tool for translating Qt applications'
- newicon src/linguist/linguist/images/icons/linguist-128-32.png linguist6.png
- fi
-
- if use pixeltool; then
- # no icon, not fitting but share with designer for now
- make_desktop_entry pixeltool6 'Qt 6 Pixel Tool' designer6 \
- 'Qt;Development' \
- 'Comment=Tool for zooming in the desktop area pointed by the cursor'
- fi
-
- if use qdbus; then
- make_desktop_entry qdbusviewer6 'Qt 6 QDBusViewer' qdbusviewer6 \
- 'Qt;Development' \
- 'Comment=Tool that lets introspect D-Bus objects and messages'
- newicon src/qdbus/qdbusviewer/images/qdbusviewer-128.png qdbusviewer6.png
- fi
-
- # hack: make_destop_entry does not support overriding DESCRIPTION
- find "${ED}" -type f -name "*.desktop" \
- -exec sed -i "/^Comment=${DESCRIPTION}/d" -- {} + || die
- fi
-}
-
-pkg_postinst() {
- use assistant &&
- optfeature "Qt documentation viewable in assistant" \
- 'dev-qt/qt-docs:6[qch]' #602296
-}