summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-09-17 23:00:17 +0200
committerMichał Górny <mgorny@gentoo.org>2019-09-17 23:00:51 +0200
commit618a0bfbf207f9ee176dcdfd16b88737a2da3c08 (patch)
tree5331f27ee0d39f649b7848db46fea7819083be47
parentsys-devel/lld: Use BDEPEND semi-properly (diff)
downloadgentoo-618a0bfbf207f9ee176dcdfd16b88737a2da3c08.tar.gz
gentoo-618a0bfbf207f9ee176dcdfd16b88737a2da3c08.tar.bz2
gentoo-618a0bfbf207f9ee176dcdfd16b88737a2da3c08.zip
sys-devel/llvm: Use BDEPEND semi-properly
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-devel/llvm/llvm-10.0.0.9999.ebuild9
-rw-r--r--sys-devel/llvm/llvm-9.0.0.9999.ebuild9
2 files changed, 10 insertions, 8 deletions
diff --git a/sys-devel/llvm/llvm-10.0.0.9999.ebuild b/sys-devel/llvm/llvm-10.0.0.9999.ebuild
index bacec8033f4e..131e44a7f887 100644
--- a/sys-devel/llvm/llvm-10.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-10.0.0.9999.ebuild
@@ -55,6 +55,9 @@ RDEPEND="
z3? ( >=sci-mathematics/z3-4.7.1:0=[${MULTILIB_USEDEP}] )"
# configparser-3.2 breaks the build (3.3 or none at all are fine)
DEPEND="${RDEPEND}
+ gold? ( sys-libs/binutils-libs )"
+BDEPEND="
+ dev-lang/perl
|| ( >=sys-devel/gcc-3.0 >=sys-devel/llvm-3.5
( >=sys-freebsd/freebsd-lib-9.1-r10 sys-libs/libcxx )
)
@@ -66,7 +69,6 @@ DEPEND="${RDEPEND}
dev-python/recommonmark[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
') )
- gold? ( sys-libs/binutils-libs )
libffi? ( virtual/pkgconfig )
!!<dev-python/configparser-3.3.0.2
${PYTHON_DEPS}"
@@ -74,7 +76,6 @@ DEPEND="${RDEPEND}
# installed means llvm-config there will take precedence.
RDEPEND="${RDEPEND}
!sys-devel/llvm:0"
-BDEPEND="dev-lang/perl"
PDEPEND="sys-devel/llvm-common
gold? ( >=sys-devel/llvmgold-${SLOT} )"
@@ -86,8 +87,8 @@ CMAKE_BUILD_TYPE=RelWithDebInfo
python_check_deps() {
use doc || return 0
- has_version "dev-python/recommonmark[${PYTHON_USEDEP}]" &&
- has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
+ has_version -b "dev-python/recommonmark[${PYTHON_USEDEP}]" &&
+ has_version -b "dev-python/sphinx[${PYTHON_USEDEP}]"
}
src_prepare() {
diff --git a/sys-devel/llvm/llvm-9.0.0.9999.ebuild b/sys-devel/llvm/llvm-9.0.0.9999.ebuild
index f294d0937069..937bff8cf3b6 100644
--- a/sys-devel/llvm/llvm-9.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-9.0.0.9999.ebuild
@@ -53,6 +53,9 @@ RDEPEND="
z3? ( >=sci-mathematics/z3-4.7.1:0=[${MULTILIB_USEDEP}] )"
# configparser-3.2 breaks the build (3.3 or none at all are fine)
DEPEND="${RDEPEND}
+ gold? ( sys-libs/binutils-libs )"
+BDEPEND="
+ dev-lang/perl
|| ( >=sys-devel/gcc-3.0 >=sys-devel/llvm-3.5
( >=sys-freebsd/freebsd-lib-9.1-r10 sys-libs/libcxx )
)
@@ -64,7 +67,6 @@ DEPEND="${RDEPEND}
dev-python/recommonmark[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
') )
- gold? ( sys-libs/binutils-libs )
libffi? ( virtual/pkgconfig )
!!<dev-python/configparser-3.3.0.2
${PYTHON_DEPS}"
@@ -72,7 +74,6 @@ DEPEND="${RDEPEND}
# installed means llvm-config there will take precedence.
RDEPEND="${RDEPEND}
!sys-devel/llvm:0"
-BDEPEND="dev-lang/perl"
PDEPEND="sys-devel/llvm-common
gold? ( >=sys-devel/llvmgold-${SLOT} )"
@@ -84,8 +85,8 @@ CMAKE_BUILD_TYPE=RelWithDebInfo
python_check_deps() {
use doc || return 0
- has_version "dev-python/recommonmark[${PYTHON_USEDEP}]" &&
- has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
+ has_version -b "dev-python/recommonmark[${PYTHON_USEDEP}]" &&
+ has_version -b "dev-python/sphinx[${PYTHON_USEDEP}]"
}
src_prepare() {