summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2019-09-28 03:01:59 +0000
committerMike Gilbert <floppym@gentoo.org>2019-09-28 22:56:14 -0400
commit618f64cbe4c3bfb29e70881dc0f2c9a2a88f086c (patch)
tree2df81e30183db355fc6a090923996df19d6d3cdd
parentapp-i18n/librime: Depend on dev-libs/boost[nls]. (diff)
downloadgentoo-618f64cbe4c3bfb29e70881dc0f2c9a2a88f086c.tar.gz
gentoo-618f64cbe4c3bfb29e70881dc0f2c9a2a88f086c.tar.bz2
gentoo-618f64cbe4c3bfb29e70881dc0f2c9a2a88f086c.zip
dev-libs/darts: Use sources from Darts-clone (fork of Darts).
Fixes: https://bugs.gentoo.org/692950 Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--dev-libs/darts/Manifest1
-rw-r--r--dev-libs/darts/darts-0.32h_pre20181117064816.ebuild57
-rw-r--r--dev-libs/darts/darts-9999.ebuild57
-rw-r--r--dev-libs/darts/metadata.xml11
4 files changed, 122 insertions, 4 deletions
diff --git a/dev-libs/darts/Manifest b/dev-libs/darts/Manifest
index 5a6424dbf094..0b6865602030 100644
--- a/dev-libs/darts/Manifest
+++ b/dev-libs/darts/Manifest
@@ -1 +1,2 @@
DIST darts-0.32.tar.gz 234001 BLAKE2B e40f16e6ead25809d981c98924867903e1d0f3734682b61ad1be40a10a4212795dfdef55a0eb6f9d0f60ef7676ed27929a6812bf8f57972dcf00875e99d9917b SHA512 b9af8ce60688f5858dac2cac35a8666848dba6729f9f4364786123a1c0484e56c8b981ec04e59653afbcf20cce3b326a49243095213efb525b5669472ac7358e
+DIST darts-0.32h_pre20181117064816.tar.gz 38856 BLAKE2B db4bf7ca88ceb81dcaee4494708d3f469dfc4f1ce53aa731f291d4b7d73f2c48a9e8d97caf32fd0bdd66aaba1c9e3e2e0289a5f2fdf7f5f1f2351c3808d6a98c SHA512 092cc833fff937365117f5b780f09a1ffdd25104ab57e36f7cba25a9a6bee289c105cae997a50b61b5b542c1c34d71bddf132d0ca14d563198b57caa9af2ac22
diff --git a/dev-libs/darts/darts-0.32h_pre20181117064816.ebuild b/dev-libs/darts/darts-0.32h_pre20181117064816.ebuild
new file mode 100644
index 000000000000..a379bd2b6cb6
--- /dev/null
+++ b/dev-libs/darts/darts-0.32h_pre20181117064816.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2003-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+WANT_LIBTOOL="none"
+
+inherit autotools
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/s-yata/darts-clone"
+else
+ DARTS_CLONE_GIT_REVISION="e40ce4627526985a7767444b6ed6893ab6ff8983"
+fi
+
+DESCRIPTION="Darts-clone (Double-ARray Trie System) C++ library"
+# Original upstream: http://chasen.org/~taku/software/darts/
+HOMEPAGE="https://github.com/s-yata/darts-clone https://code.google.com/archive/p/darts-clone/"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/s-yata/darts-clone/archive/${DARTS_CLONE_GIT_REVISION}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+BDEPEND=""
+DEPEND=""
+RDEPEND=""
+
+if [[ "${PV}" != "9999" ]]; then
+ S="${WORKDIR}/darts-clone-${DARTS_CLONE_GIT_REVISION}"
+fi
+
+src_prepare() {
+ default
+ eaclocal
+ eautoconf
+ eautomake
+}
+
+src_install() {
+ default
+
+ local language source_file target_file
+ for source_file in doc/*/*.md; do
+ language="${source_file#*/}"
+ language="${language%%/*}"
+ target_file="${source_file##*/}"
+ target_file="${target_file%.md}.${language}.md"
+ newdoc "${source_file}" "${target_file}"
+ done
+}
diff --git a/dev-libs/darts/darts-9999.ebuild b/dev-libs/darts/darts-9999.ebuild
new file mode 100644
index 000000000000..556c583634b1
--- /dev/null
+++ b/dev-libs/darts/darts-9999.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2003-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+WANT_LIBTOOL="none"
+
+inherit autotools
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/s-yata/darts-clone"
+else
+ DARTS_CLONE_GIT_REVISION=""
+fi
+
+DESCRIPTION="Darts-clone (Double-ARray Trie System) C++ library"
+# Original upstream: http://chasen.org/~taku/software/darts/
+HOMEPAGE="https://github.com/s-yata/darts-clone https://code.google.com/archive/p/darts-clone/"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/s-yata/darts-clone/archive/${DARTS_CLONE_GIT_REVISION}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+BDEPEND=""
+DEPEND=""
+RDEPEND=""
+
+if [[ "${PV}" != "9999" ]]; then
+ S="${WORKDIR}/darts-clone-${DARTS_CLONE_GIT_REVISION}"
+fi
+
+src_prepare() {
+ default
+ eaclocal
+ eautoconf
+ eautomake
+}
+
+src_install() {
+ default
+
+ local language source_file target_file
+ for source_file in doc/*/*.md; do
+ language="${source_file#*/}"
+ language="${language%%/*}"
+ target_file="${source_file##*/}"
+ target_file="${target_file%.md}.${language}.md"
+ newdoc "${source_file}" "${target_file}"
+ done
+}
diff --git a/dev-libs/darts/metadata.xml b/dev-libs/darts/metadata.xml
index c921b96adf6c..bb2998c433a2 100644
--- a/dev-libs/darts/metadata.xml
+++ b/dev-libs/darts/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>cjk@gentoo.org</email>
- <name>Cjk</name>
-</maintainer>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">s-yata/darts-clone</remote-id>
+ </upstream>
</pkgmetadata>