summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-05-01 15:30:33 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-05-01 15:30:33 +0200
commit6197d53d7b22a0045847111c7261784a452f3a5d (patch)
tree7d28208359207252a581e590b8e4108fbfe5541f
parentdev-libs/userspace-rcu: bump to v0.12.1 (diff)
downloadgentoo-6197d53d.tar.gz
gentoo-6197d53d.tar.bz2
gentoo-6197d53d.zip
dev-libs/nettle: add USE=asm
Closes: https://bugs.gentoo.org/710122 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--dev-libs/nettle/metadata.xml3
-rw-r--r--dev-libs/nettle/nettle-3.6.ebuild3
2 files changed, 5 insertions, 1 deletions
diff --git a/dev-libs/nettle/metadata.xml b/dev-libs/nettle/metadata.xml
index d67991097866..1762d3327574 100644
--- a/dev-libs/nettle/metadata.xml
+++ b/dev-libs/nettle/metadata.xml
@@ -8,4 +8,7 @@
<upstream>
<remote-id type="cpe">cpe:/a:nettle_project:nettle</remote-id>
</upstream>
+ <use>
+ <flag name="asm">Support assembly hand optimized crypto functions (i.e. faster run time)</flag>
+ </use>
</pkgmetadata>
diff --git a/dev-libs/nettle/nettle-3.6.ebuild b/dev-libs/nettle/nettle-3.6.ebuild
index 6131eaec35e8..865b190a4cbd 100644
--- a/dev-libs/nettle/nettle-3.6.ebuild
+++ b/dev-libs/nettle/nettle-3.6.ebuild
@@ -12,7 +12,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="|| ( LGPL-3 LGPL-2.1 )"
SLOT="0/7" # subslot = libnettle soname version
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc +gmp neon static-libs test cpu_flags_x86_aes cpu_flags_x86_sha"
+IUSE="+asm doc +gmp neon static-libs test cpu_flags_x86_aes cpu_flags_x86_sha"
RESTRICT="!test? ( test )"
DEPEND="gmp? ( >=dev-libs/gmp-6.1:0=[static-libs?,${MULTILIB_USEDEP}] )"
@@ -52,6 +52,7 @@ multilib_src_configure() {
$(tc-is-static-only && echo --disable-shared) \
$(use_enable cpu_flags_x86_aes x86-aesni) \
$(use_enable cpu_flags_x86_sha x86-sha-ni) \
+ $(use_enable asm assembler)
$(use_enable doc documentation) \
$(use_enable gmp public-key) \
$(use_enable neon arm-neon) \