summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-26 05:25:41 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-26 06:48:59 +0200
commit619867745eb3b0455741cfc7bea47092d68166cc (patch)
tree878d53b4e7aae570084988aa45b9965061ad7af2
parentdev-python/hypothesis: Bump to 6.47.5 (diff)
downloadgentoo-619867745eb3b0455741cfc7bea47092d68166cc.tar.gz
gentoo-619867745eb3b0455741cfc7bea47092d68166cc.tar.bz2
gentoo-619867745eb3b0455741cfc7bea47092d68166cc.zip
dev-python/sphinxcontrib-spelling: Bump to 7.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinxcontrib-spelling/Manifest1
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.6.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-spelling/Manifest b/dev-python/sphinxcontrib-spelling/Manifest
index a867f30e2efd..d43c67bfb3e7 100644
--- a/dev-python/sphinxcontrib-spelling/Manifest
+++ b/dev-python/sphinxcontrib-spelling/Manifest
@@ -1,3 +1,4 @@
DIST sphinxcontrib-spelling-7.3.3.tar.gz 51912 BLAKE2B 6a9bd90db2298beb78686252d555dd5e77d0c9042eb0986dd2eeab9e413a921c5f5f594c539c2cfe6315002c2f2892241b789b10976e634158f3ca1d8be1b627 SHA512 7406bd846c5eac507f8e4481ada4d0d725d0a3ad8cf2f8fd3328389128cf54091bb0e304dfe23fdf771a26d9103d2c028d2f7f29e1949ca59fcf43de5bac9cb1
DIST sphinxcontrib-spelling-7.5.0.tar.gz 54978 BLAKE2B ed56e27434a43d688a63ff6ca8aa7889a80a0a750abdebc5e9307c68fae8a14ae7ba065b127c583fff11499e75750aee6f017b4d442204b1a2308a5c8692e73c SHA512 d306d19664990cfb6ceff947f3a34243a8ead95b0e6076f9da924cd0ef43e2621178bd374400f805970592f803d6a129c74a32a6c6837d41e4f72118da667138
DIST sphinxcontrib-spelling-7.5.1.tar.gz 55547 BLAKE2B 61415fb62b0d47672901048276897d7578f891732278d9ea0b4fe0ca5f42654114f76d600ffcf0f602afe1c0d46f4bf466c326337accf910090f768c1cee1c69 SHA512 d38114421e519ed127eae712637677a8ae75cc640087d2e7740d8c106a0d7058e633f65fb1ac9ee2fa75d295b218aa98d3a3279b077f2a89ea947a3b4c0fd05a
+DIST sphinxcontrib-spelling-7.6.0.tar.gz 56329 BLAKE2B e26a3fcb39edf622b20bce0d79d1ce2d2a13e4dd8bdef0bb5cc31108a8ee42afd728975fd65e840c91bc6c6510a57904ebc478b458a52a96031bf44f1cbfa8b6 SHA512 102202eb73767ffface2aa5555c8ee2658bcd3c1eb7f3a925e8713e2f233d1bcf0eb307fed6c264c4e4e6503c30d83a3025b0c39ef608451d2fe86664aeb48c5
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.6.0.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.6.0.ebuild
new file mode 100644
index 000000000000..834977197c58
--- /dev/null
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.6.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx spelling extension"
+HOMEPAGE="
+ https://github.com/sphinx-contrib/spelling/
+ https://pypi.org/project/sphinxcontrib-spelling/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ app-dicts/myspell-en
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires the git repo
+ tests/test_filter.py::test_contributors
+)
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ distutils_write_namespace sphinxcontrib
+ rm -rf sphinxcontrib || die
+ epytest tests
+}