summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-12-28 15:47:56 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-28 15:47:56 +0100
commit619c992fe93b9a66447100caeca9dde0d71e6399 (patch)
treee9224529d9901114f06e22c31616987fcd1ba348
parentmedia-gfx/freewrl: Fix build with gcc-10 (diff)
downloadgentoo-619c992f.tar.gz
gentoo-619c992f.tar.bz2
gentoo-619c992f.zip
net-misc/sipsak: Bump to 0.9.8
Closes: https://bugs.gentoo.org/706350 Closes: https://bugs.gentoo.org/757321 Package-Manager: Portage-3.0.9, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--net-misc/sipsak/Manifest1
-rw-r--r--net-misc/sipsak/sipsak-0.9.8.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/net-misc/sipsak/Manifest b/net-misc/sipsak/Manifest
index b5b8efabd035..a4e63848959f 100644
--- a/net-misc/sipsak/Manifest
+++ b/net-misc/sipsak/Manifest
@@ -1 +1,2 @@
DIST sipsak-0.9.7.tar.gz 199074 BLAKE2B c99bc7ace4eb5f1af193d64d156243904300e1f5fc66d1a44f578970e0d8242be3c8fa82804bfc975efcaaf6b5289c0b09b22b8d5c069fc81a16c343136be49b SHA512 695ba6e596411fdda14e6800163b934dba2dc6ee661ebc91a9f3d3509b9568d0482108fb50503953f7f9186cf11724c0faf4660436aad1929f4a70dc41286402
+DIST sipsak-0.9.8.tar.gz 202482 BLAKE2B 26ea0fc196d598f6ef111b0c511484db0ca23b4ea8e2febe957b578a5eb0e2351dcc1d5848bdcda4a01f6962d1cd97c80dcf58203fcb82e19eb7f475f8a7ee56 SHA512 1cd4c8e69f5c8cae83c524f73ef53eb139127ff3652eb1407542883c4c3593df9d61207e10198705e064b42da72c210fb6a88c087a83c3b13bbb6d9d8bfab20c
diff --git a/net-misc/sipsak/sipsak-0.9.8.ebuild b/net-misc/sipsak/sipsak-0.9.8.ebuild
new file mode 100644
index 000000000000..c16b38b851c7
--- /dev/null
+++ b/net-misc/sipsak/sipsak-0.9.8.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="small command line tool for testing SIP applications and devices"
+HOMEPAGE="https://github.com/nils-ohlmeier/sipsak"
+SRC_URI="https://github.com/nils-ohlmeier/sipsak/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
+
+RDEPEND="
+ net-dns/c-ares
+ net-libs/gnutls:="
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ append-cflags -std=gnu89 -fcommon
+ econf
+}