summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-04 13:19:26 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-06 06:23:19 +1200
commit61bc0f8afdf972dd66650ad412ea7a2159f73250 (patch)
treee028ee1f3dc6f93fc8f22373da8531f482edb4c5
parentdev-perl/CSS-Minifier-XS: -r bump for EAPI7 + toolchain love (diff)
downloadgentoo-61bc0f8afdf972dd66650ad412ea7a2159f73250.tar.gz
gentoo-61bc0f8afdf972dd66650ad412ea7a2159f73250.tar.bz2
gentoo-61bc0f8afdf972dd66650ad412ea7a2159f73250.zip
dev-perl/Cache-FastMmap: -r bump for CFLAGS love
- Ensure CFLAGS passed through to make/compile Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
-rw-r--r--dev-perl/Cache-FastMmap/Cache-FastMmap-1.490.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/Cache-FastMmap/Cache-FastMmap-1.490.0-r1.ebuild b/dev-perl/Cache-FastMmap/Cache-FastMmap-1.490.0-r1.ebuild
new file mode 100644
index 000000000000..4d61b8f8c8d9
--- /dev/null
+++ b/dev-perl/Cache-FastMmap/Cache-FastMmap-1.490.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DIST_AUTHOR=ROBM
+DIST_VERSION=1.49
+inherit perl-module
+
+DESCRIPTION="Uses an mmaped file to act as a shared memory interprocess cache"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/perl-Storable
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}