summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-03-17 10:33:56 +0200
committerMart Raudsepp <leio@gentoo.org>2020-03-17 10:33:56 +0200
commit61bf2db72673d893d988c63b3ad97dedd180d2e5 (patch)
treeb833da07831b34c2de105900b7a257c937c51e43
parentgnome-base/librsvg: security cleanup (diff)
downloadgentoo-61bf2db7.tar.gz
gentoo-61bf2db7.tar.bz2
gentoo-61bf2db7.zip
app-text/iso-codes: remove old
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--app-text/iso-codes/Manifest1
-rw-r--r--app-text/iso-codes/iso-codes-3.76.ebuild78
2 files changed, 0 insertions, 79 deletions
diff --git a/app-text/iso-codes/Manifest b/app-text/iso-codes/Manifest
index 2688b2e11990..5d9ae1fe8702 100644
--- a/app-text/iso-codes/Manifest
+++ b/app-text/iso-codes/Manifest
@@ -1,2 +1 @@
-DIST iso-codes-3.76.tar.xz 3474728 BLAKE2B b418b7b80d1926e765b65aad4edbd74ad8d37251fda14e3ab0e222095762d54e358de6f8d4a08fde8ae14460fd975a2a541ca6a5a4cf8ef1d777719462b0f991 SHA512 a0f6714a79a52b5dab82a268e85cb2d019ff5255744b88d088dcd7d5a15eb9710876a338a0a5d0f5659b4146bc6cc53d6d3474d621b3dcca7c47afabfc7e0dfa
DIST iso-codes-4.4.tar.gz 13299605 BLAKE2B 485f3b0240f1892fb96f2b5c391b3f0adc593fac97d53748aa104208936d1bf81de1d40e742ab48e3663cea0ce5b28a20782df2f4eed251bab5b8a7055745d0e SHA512 d22ecdef75cd07b59ea0dbc87d25eb254676ab83297c1a43dbad9d3471ba355630f5588b4590972526f9e885b2e1ec307303ac0bb94b2dd5c707377c1cfa64d8
diff --git a/app-text/iso-codes/iso-codes-3.76.ebuild b/app-text/iso-codes/iso-codes-3.76.ebuild
deleted file mode 100644
index 13eee6bba9c5..000000000000
--- a/app-text/iso-codes/iso-codes-3.76.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{6,7} )
-PLOCALES="af am ar as ast az be bg bn bn_IN br bs byn ca crh cs cy da de dz el en eo es et eu fa fi fo fr ga gez gl gu haw he hi hr hu hy ia id is it ja ka kk km kn ko kok ku lt lv mi mk ml mn mr ms mt nb ne nl nn nso oc or pa pl ps pt pt_BR ro ru rw si sk sl so sq sr sr@latin sv sw ta te th ti tig tk tl tr tt tt@iqtelif ug uk ve vi wa wal wo xh zh_CN zh_HK zh_TW zu"
-
-inherit eutils l10n python-any-r1
-
-DESCRIPTION="ISO language, territory, currency, script codes and their translations"
-HOMEPAGE="https://salsa.debian.org/iso-codes-team/iso-codes"
-SRC_URI="http://pkg-isocodes.alioth.debian.org/downloads/${P}.tar.xz"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${PYTHON_DEPS}
- app-arch/xz-utils
- sys-devel/gettext
-"
-
-# This ebuild does not install any binaries.
-RESTRICT="binchecks strip"
-
-# l10n_find_plocales_changes doesn't support multiple directories,
-# so need to do the update scan ourselves.
-check_existing_locales() {
- local std loc all_locales=()
-
- ebegin "Looking for new locales"
- for std in "${all_stds[@]}"; do
- pushd "${std}" >/dev/null || die
- for loc in *.po; do
- all_locales+=( "${loc%.po}" )
- done
- popd >/dev/null
- done
-
- all_locales=$(echo $(printf '%s\n' "${all_locales[@]}" | LC_COLLATE=C sort -u))
- if [[ ${PLOCALES} != "${all_locales}" ]]; then
- eend 1
- eerror "There are changes in locales! This ebuild should be updated to:"
- eerror "PLOCALES=\"${all_locales}\""
- die "Update PLOCALES in the ebuild"
- else
- eend 0
- fi
-}
-
-src_prepare() {
- default
-
- local std loc mylinguas
- local all_stds=( iso_15924 iso_3166-{1,2,3} iso_4217 iso_639-{2,3,5} )
-
- check_existing_locales
-
- # Modify the Makefiles so they only install requested locales.
- for std in "${all_stds[@]}"; do
- einfo "Preparing ${std} ..."
- pushd "${std}" >/dev/null || die
- mylinguas=()
- for loc in *.po; do
- if has ${loc%.po} ${LINGUAS-${loc%.po}}; then
- mylinguas+=( "${loc}" )
- fi
- done
-
- sed \
- -e "/^pofiles =/s:=.*:= ${mylinguas[*]}:" \
- -e "/^mofiles =/s:=.*:= ${mylinguas[*]/%.po/.mo}:" \
- -i Makefile.am Makefile.in || die "sed in ${std} folder failed"
- popd >/dev/null
- done
-}