summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-02 08:13:17 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-02 08:37:25 +0100
commit61c2308ded897597ecb6946282453b7d63bd7553 (patch)
tree0e0b4aafe2c841b21602de4138b16fb62b956eaf
parentdev-python/Faker: Bump to 15.1.3 (diff)
downloadgentoo-61c2308d.tar.gz
gentoo-61c2308d.tar.bz2
gentoo-61c2308d.zip
dev-python/pytest-trio: Bump to 0.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-trio/Manifest1
-rw-r--r--dev-python/pytest-trio/pytest-trio-0.8.0.ebuild51
-rw-r--r--profiles/features/wd40/package.mask1
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pytest-trio/Manifest b/dev-python/pytest-trio/Manifest
index e39be86a7c57..0670ecdc7a53 100644
--- a/dev-python/pytest-trio/Manifest
+++ b/dev-python/pytest-trio/Manifest
@@ -1 +1,2 @@
DIST pytest-trio-0.7.0.tar.gz 47784 BLAKE2B 59b28df45e87804e0b6eb557a0cf259fdc3636cc7a03d78248fb814d55904ed01d00a530b194b2bfe93ccfb9de528d70a372faf1f6db24531c230319122db2e5 SHA512 547036c94f33cf8e755c88d608c5fddfa5c583fdaa7e604598d470e250a006c571702a81bac4f273b74450a8c10e4be404bad74d4104403fe1c9c70e872dff53
+DIST pytest-trio-0.8.0.tar.gz 46525 BLAKE2B 54660dc9b021af0ec18eace72f053223d16e89635c74d71329a005e5fee3bf6e2055cc29412d9de7443b2594ee53d68890d1e30ed7c94560c355d4342bb3d035 SHA512 79141021633b7b2d8a840d7eaf6a3447bccd59d1bd4909e7feba88a9ae8244376f281b64fde4333b5a575957e3f73028e389a9abf0d19a35417f15c47eeccd05
diff --git a/dev-python/pytest-trio/pytest-trio-0.8.0.ebuild b/dev-python/pytest-trio/pytest-trio-0.8.0.ebuild
new file mode 100644
index 000000000000..b45ef14decb2
--- /dev/null
+++ b/dev-python/pytest-trio/pytest-trio-0.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="This is a pytest plugin to help you test projects that use Trio"
+HOMEPAGE="
+ https://github.com/python-trio/pytest-trio
+ https://pypi.org/project/pytest-trio/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/outcome-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7.2.0[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.22.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source \
+ dev-python/attrs \
+ dev-python/sphinx_rtd_theme \
+ dev-python/sphinxcontrib-trio
+
+python_prepare_all() {
+ # Defining 'pytest_plugins' in a non-top-level conftest is no longer supported:
+ mv pytest_trio/_tests/conftest.py conftest.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # disable autoloading pytest-asyncio in nested pytest calls
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # since we disabled autoloading, force loading pytest-trio
+ local -x PYTEST_PLUGINS=pytest_trio.plugin
+ epytest
+}
diff --git a/profiles/features/wd40/package.mask b/profiles/features/wd40/package.mask
index 55b305242c18..314a96313cfb 100644
--- a/profiles/features/wd40/package.mask
+++ b/profiles/features/wd40/package.mask
@@ -34,6 +34,7 @@ dev-python/osc-lib
dev-python/paramiko
>=dev-python/pyopenssl-22
dev-python/pyspnego
+>=dev-python/pytest-trio-0.8.0
dev-python/python-daemon
dev-python/python-glanceclient
dev-python/python-ironicclient