summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-22 09:01:35 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-22 09:30:08 +0100
commit61c4042fa6f439de8e1c273682c754488e4326d4 (patch)
treeeec77df5f2e4724b9fe9de75a7fd1923d72dd967
parentdev-python/greenlet: Bump to 3.0.3 (diff)
downloadgentoo-61c4042fa6f439de8e1c273682c754488e4326d4.tar.gz
gentoo-61c4042fa6f439de8e1c273682c754488e4326d4.tar.bz2
gentoo-61c4042fa6f439de8e1c273682c754488e4326d4.zip
dev-python/apispec: Bump to 6.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/apispec/Manifest1
-rw-r--r--dev-python/apispec/apispec-6.3.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/apispec/Manifest b/dev-python/apispec/Manifest
index 5d4d8a1b6dfa..882c467db34e 100644
--- a/dev-python/apispec/Manifest
+++ b/dev-python/apispec/Manifest
@@ -1 +1,2 @@
DIST apispec-6.3.0.tar.gz 77157 BLAKE2B 0ccf398f36548ea269c4e91fb512d8789bb387cff6956c0fe0426f1b3c38b6670e8c41972948d7a3f87c75e52c97fdff7570306d64c6ad41bfcb9f19e391b7de SHA512 65119851ee31cebc0bb0ddc6668e3961f870a7759bc95128e67063d0f3c6a88ddb590efc478c2e8eb8ecd7d3edd51bd51971a4e3e1e25a7486dfcb1b49e98dc4
+DIST apispec-6.3.1.tar.gz 77634 BLAKE2B e98a4d14f12248b27af1b5b12b642e416af7cf4f36386406ad0784e7d8930a71391de2ed627d6093e907048bb3a145abf06fca1b5b3e0595346d45fd6be6775f SHA512 977d9f890728a336b8e604f5ab7feb850f0f65e9fb64aa10cb2697d27bbd89137c6b08719b6cc422efc11c80cea6f6646709c33d340b0a63345fe93f2aa92902
diff --git a/dev-python/apispec/apispec-6.3.1.ebuild b/dev-python/apispec/apispec-6.3.1.ebuild
new file mode 100644
index 000000000000..a64dc15f67a5
--- /dev/null
+++ b/dev-python/apispec/apispec-6.3.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pluggable API specification generator"
+HOMEPAGE="
+ https://github.com/marshmallow-code/apispec/
+ https://pypi.org/project/apispec/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ >=dev-python/marshmallow-3.18.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-issues \
+ dev-python/sphinx-rtd-theme
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires unpackaged prance
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v2
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v3
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}