summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-01-17 21:52:51 +0100
committerMarek Szuba <marecki@gentoo.org>2022-01-17 22:08:00 +0100
commit61db20a923d2f8874d108cdf030e697eb74cd188 (patch)
tree09c01a1dd66072c00966f05990faa12e1ade32ef
parentdev-python/pyopencl: add 2021.2.13, drop 2021.2.11 (diff)
downloadgentoo-61db20a923d2f8874d108cdf030e697eb74cd188.tar.gz
gentoo-61db20a923d2f8874d108cdf030e697eb74cd188.tar.bz2
gentoo-61db20a923d2f8874d108cdf030e697eb74cd188.zip
dev-python/cerberus: add 1.3.4
No DISTUTILS_USE_PEP517 yet because it causes import errors in the test suite. Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--dev-python/cerberus/Manifest1
-rw-r--r--dev-python/cerberus/cerberus-1.3.4.ebuild29
-rw-r--r--dev-python/cerberus/files/cerberus-1.3.4-raw_docstrings.patch23
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/cerberus/Manifest b/dev-python/cerberus/Manifest
index 59e83aabb5d5..47e18720ce95 100644
--- a/dev-python/cerberus/Manifest
+++ b/dev-python/cerberus/Manifest
@@ -1 +1,2 @@
DIST cerberus-1.3.2.tar.gz 149344 BLAKE2B ce65f3c4c612f87562c28f913cac95c1c7af9b2dfa72955bce3f0e0459e4ff9024a126ceea4587e2c72cf606be2a249046a090a2e2d5e908bfe4b700ba5e9b92 SHA512 e9cfef5a936783eb0576afd3d23397dab38d8c88b6b43f98de0ad7e20739e5ff983eaf4ac769206adb7fe9692c651583f6a5f2bab263b81b8de96f45707c84fb
+DIST cerberus-1.3.4.tar.gz 926258 BLAKE2B 6fabfcf32e26ee7f4881b64ce9c3098a27949d95fd0998e09b7adcc3b834033f904a07b6e9b2cadea218b952142f6c2bc6051d8c208a14d6e8172a0c3823c38b SHA512 c816b426ed1b32367d1e8f1c26d6ddd4b49c6578540e688baf693e3094a05800f645cfe879be6378c1e9be9899cad7bc2ad1ed9844d6762d2ef6e0cc54a7476a
diff --git a/dev-python/cerberus/cerberus-1.3.4.ebuild b/dev-python/cerberus/cerberus-1.3.4.ebuild
new file mode 100644
index 000000000000..74d544b5ff1f
--- /dev/null
+++ b/dev-python/cerberus/cerberus-1.3.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A lightweight and extensible data-validation library for Python"
+HOMEPAGE="https://docs.python-cerberus.org/"
+SRC_URI="https://github.com/pyeve/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.2_no-pytest-runner.patch
+ "${FILESDIR}"/${PN}-1.3.4-raw_docstrings.patch
+)
+
+# Require currently unpackaged pytest-benchmark, more useful to developers than to end users.
+EPYTEST_DESELECT=(
+ cerberus/benchmarks/
+)
+
+distutils_enable_tests pytest
diff --git a/dev-python/cerberus/files/cerberus-1.3.4-raw_docstrings.patch b/dev-python/cerberus/files/cerberus-1.3.4-raw_docstrings.patch
new file mode 100644
index 000000000000..70ba15b0445f
--- /dev/null
+++ b/dev-python/cerberus/files/cerberus-1.3.4-raw_docstrings.patch
@@ -0,0 +1,23 @@
+Addresses https://github.com/pyeve/cerberus/issues/568.
+Backported upstream commit 5c267b554a39b5a8650659d3eea0cf383e47a166.
+
+--- a/cerberus/errors.py
++++ b/cerberus/errors.py
+@@ -153,7 +153,7 @@
+
+ @property
+ def definitions_errors(self):
+- """
++ r"""
+ Dictionary with errors of an \*of-rule mapped to the index of the definition it
+ occurred in. Returns :obj:`None` if not applicable.
+ """
+@@ -181,7 +181,7 @@
+
+ @property
+ def is_logic_error(self):
+- """
++ r"""
+ ``True`` for validation errors against different schemas with \*of-rules.
+ """
+ return bool(self.code & LOGICAL.code - ERROR_GROUP.code)