summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2023-12-25 17:39:39 +0200
committerMart Raudsepp <leio@gentoo.org>2023-12-25 19:13:58 +0200
commit61dfbb83a61d0e5ee3e6822f22b1d3a3bb1afbb9 (patch)
tree2b4856067319b3094f28abd932ff02498c0a2022
parentdev-libs/appstream: drop 1.0.0 (diff)
downloadgentoo-61dfbb83a61d0e5ee3e6822f22b1d3a3bb1afbb9.tar.gz
gentoo-61dfbb83a61d0e5ee3e6822f22b1d3a3bb1afbb9.tar.bz2
gentoo-61dfbb83a61d0e5ee3e6822f22b1d3a3bb1afbb9.zip
x11-wm/mutter: fix USE=-wayland build; add various upstream fixes
Upstream patchset up to current state of stable branch most notably includes: * fixes compatibility with xdg-desktop-portal-gnome-45.1 * some important NVIDIA EGLStream fix when that ends up used (with e.g. MUTTER_DEBUG_FORCE_EGL_STREAM=1) * window size and related fixes when moving fullscreen window across differently sized monitors * fixes handling of relative mode for tablet * improvements for desktop icons extension purposes * much more Closes: https://bugs.gentoo.org/914571 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--x11-wm/mutter/Manifest1
-rw-r--r--x11-wm/mutter/files/45.2-fix-X-only.patch48
-rw-r--r--x11-wm/mutter/mutter-45.2-r1.ebuild239
3 files changed, 288 insertions, 0 deletions
diff --git a/x11-wm/mutter/Manifest b/x11-wm/mutter/Manifest
index 46cee7d21b3a..d9669bb68553 100644
--- a/x11-wm/mutter/Manifest
+++ b/x11-wm/mutter/Manifest
@@ -1,4 +1,5 @@
DIST mutter-44.3.tar.xz 2848256 BLAKE2B 42c00d4673cab5d119361c6eb2b78c33894c637b36a34f9b74eb5a19ca621d3458208be020216f9a8949e8b0a9c9de697662c5aebb11f70bc83173ce33c7a1eb SHA512 d29bc6c7407ba81be0b5bfa2333bc77c09f7a084e09d6902cad8ca8e64ba75a22652b68a4e84b79b80481d9a7b6cb490128113dcd125ed5bcd5423d4ec88fb35
DIST mutter-44.4.tar.xz 2847392 BLAKE2B 2ecdb0d447c0426a7e02f4d3b3cdf8936a6c7a5fecad163bdba9428f018e0ceb2047b241422bc9de5e9d0fb08e88a04d572d1b404b48d6df214a7263292309ba SHA512 3f7b37be5531e270c071fc9784a6a284a3d715dfd1dfc854779126197d6e53c660836412ba08e6233747c7b016926114a57be5adb36a11c8ec9c81e333ce668c
DIST mutter-45.1.tar.xz 2881852 BLAKE2B 40fa8de01ecae346d2b9a352d55cb9215e3b9c88d7424c567fd63aa97dc7aa7cc202fdda298a4a8a9bc08330b6db3895d5860b8c99daaa4974dbd07f0ac8b86a SHA512 87a629e941eb231d05fc24dbb905acb12236c971a02dd000fdd6cc6e7686544b5796ce57d10b34e096dc956578a373d5a73e89760bcc6beb292e9a25ce2faaf4
+DIST mutter-45.2-r1-patchset.tar.xz 21864 BLAKE2B c09566f75a816f6599ac4bf99879cc0e3bb78220c56cc4bd64edabf00e533a5feb4decdaa75ef5ae7ade911ec266ba6dd4641f1cbcd2c3145c10d5a8d327d653 SHA512 dd953afb97c4cdd9e24b2eab6636472e526042eb768c23e0d5bd49cd3ceb3a5cebd3ff396d014bdf168de81f810cef754efbb1739350fc09f6d196461de41ea4
DIST mutter-45.2.tar.xz 2884940 BLAKE2B c4107840b8bd0f75a9c76300f324bfff6aac3195f526ab88102c831df693cb8dfa5b55bb1590a54e68f41eab392e69bb833221480578a2fba4b1e4bdc5ed030d SHA512 2111ad0645d2da58dedb30d94e99b52045f38b31a9de7314a5d8b41a5525612d88d2fbaafd3658eb6f734c143ad12176367c26533237199d9a5c1ad3dea743c7
diff --git a/x11-wm/mutter/files/45.2-fix-X-only.patch b/x11-wm/mutter/files/45.2-fix-X-only.patch
new file mode 100644
index 000000000000..2e76277e2607
--- /dev/null
+++ b/x11-wm/mutter/files/45.2-fix-X-only.patch
@@ -0,0 +1,48 @@
+From e2ef4e1504a40d62b45167d7cacfea0322a78134 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Mon, 25 Dec 2023 14:51:46 +0200
+Subject: [PATCH] build: Fix building without wayland headers
+
+Fixes: https://gitlab.gnome.org/GNOME/mutter/-/issues/3046
+---
+ src/backends/x11/nested/meta-backend-x11-nested.c | 2 ++
+ src/core/meta-context-main.c | 2 +-
+ 2 files changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/src/backends/x11/nested/meta-backend-x11-nested.c b/src/backends/x11/nested/meta-backend-x11-nested.c
+index 17e6f7e47..0d99078ea 100644
+--- a/src/backends/x11/nested/meta-backend-x11-nested.c
++++ b/src/backends/x11/nested/meta-backend-x11-nested.c
+@@ -25,7 +25,9 @@
+ #include "backends/x11/nested/meta-cursor-renderer-x11-nested.h"
+ #include "backends/x11/nested/meta-renderer-x11-nested.h"
+
++#ifdef HAVE_WAYLAND
+ #include "wayland/meta-wayland.h"
++#endif
+
+ typedef struct _MetaBackendX11NestedPrivate
+ {
+diff --git a/src/core/meta-context-main.c b/src/core/meta-context-main.c
+index 9c94183b5..a0ac7c823 100644
+--- a/src/core/meta-context-main.c
++++ b/src/core/meta-context-main.c
+@@ -33,7 +33,6 @@
+ #include "backends/meta-virtual-monitor.h"
+ #include "backends/x11/cm/meta-backend-x11-cm.h"
+ #include "meta/meta-backend.h"
+-#include "wayland/meta-wayland.h"
+ #include "x11/session.h"
+
+ #ifdef HAVE_NATIVE_BACKEND
+@@ -42,6 +41,7 @@
+
+ #ifdef HAVE_WAYLAND
+ #include "backends/x11/nested/meta-backend-x11-nested.h"
++#include "wayland/meta-wayland.h"
+ #endif
+
+ typedef struct _MetaContextMainOptions
+--
+2.43.0
+
diff --git a/x11-wm/mutter/mutter-45.2-r1.ebuild b/x11-wm/mutter/mutter-45.2-r1.ebuild
new file mode 100644
index 000000000000..29a2b57bbc04
--- /dev/null
+++ b/x11-wm/mutter/mutter-45.2-r1.ebuild
@@ -0,0 +1,239 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+inherit gnome.org gnome2-utils meson python-any-r1 udev xdg
+
+DESCRIPTION="GNOME compositing window manager based on Clutter"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/mutter/"
+SRC_URI+=" https://dev.gentoo.org/~leio/distfiles/${PF}-patchset.tar.xz"
+LICENSE="GPL-2+"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/mutter.git"
+ SRC_URI=""
+ SLOT="0/13" # This can get easily out of date, but better than 9967
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+ SLOT="0/$(($(ver_cut 1) - 32))" # 0/libmutter_api_version - ONLY gnome-shell (or anything using mutter-clutter-<api_version>.pc) should use the subslot
+fi
+
+IUSE="debug elogind gnome gtk-doc input_devices_wacom +introspection screencast sysprof systemd test udev wayland video_cards_nvidia"
+# native backend requires gles3 for hybrid graphics blitting support, udev and a logind provider
+REQUIRED_USE="
+ gtk-doc? ( introspection )
+ wayland? ( ^^ ( elogind systemd ) udev )
+ test? ( wayland )"
+RESTRICT="!test? ( test )"
+
+# gnome-settings-daemon is build checked, but used at runtime only for org.gnome.settings-daemon.peripherals.keyboard gschema
+# USE=libei was first introduced in xwayland-23.2.1; we min dep on that to ensure the [libei(+)] works right, as missing USE flag with
+# previous versions meant that it's not there, while the intention seems to be to make it always enabled without USE flag in the future;
+# this ensures have_enable_ei_portal is always there in xwayland.pc, which affects how Xwayland is launched, thus if it were toggled off
+# in Xwayland after mutter is installed, Xwayland would fail to be started by mutter. mutter already hard-depends on libei, so there's
+# really no extra deps here (besides xdg-desktop-portal, but we want that too, anyhow).
+# v3.32.2 has many excessive or unused *_req variables declared, thus currently the dep order ignores those and goes via dependency() call order
+DEPEND="
+ >=media-libs/graphene-1.10.2[introspection?]
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/pango-1.46[introspection?]
+ >=x11-libs/cairo-1.14[X]
+ >=dev-libs/fribidi-1.0.0
+ >=gnome-base/gsettings-desktop-schemas-42.0[introspection?]
+ >=dev-libs/glib-2.75.1:2
+ gnome-base/gnome-settings-daemon
+ >=dev-libs/json-glib-0.12.0[introspection?]
+ >=x11-libs/libxkbcommon-0.4.3
+ x11-libs/libICE
+ >=app-accessibility/at-spi2-core-2.46:2[introspection?]
+ sys-apps/dbus
+ >=x11-misc/colord-1.4.5:=
+ >=media-libs/lcms-2.6:2
+ >=media-libs/harfbuzz-2.6.0:=
+ >=dev-libs/libei-1.0.901
+
+ gnome? ( gnome-base/gnome-desktop:4= )
+
+ >=media-libs/libcanberra-0.26
+
+ media-libs/libglvnd[X]
+
+ wayland? (
+ >=dev-libs/wayland-protocols-1.32
+ >=dev-libs/wayland-1.21.0
+
+ x11-libs/libdrm
+ media-libs/mesa[gbm(+)]
+ >=dev-libs/libinput-1.19.0:=
+
+ elogind? ( sys-auth/elogind )
+ >=x11-base/xwayland-23.2.1[libei(+)]
+ video_cards_nvidia? ( gui-libs/egl-wayland )
+ )
+ udev? (
+ >=virtual/libudev-232-r1:=
+ >=dev-libs/libgudev-232
+ )
+ systemd? ( sys-apps/systemd )
+ x11-libs/libSM
+ input_devices_wacom? ( >=dev-libs/libwacom-0.13:= )
+ >=x11-libs/startup-notification-0.7
+ screencast? ( >=media-video/pipewire-0.3.33:= )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ test? (
+ >=x11-libs/gtk+-3.19.8:3[X,introspection?]
+ gnome-extra/zenity
+ )
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 >=dev-util/sysprof-3.46.0 )
+"
+# for now upstream has "have_x11 = true" in the meson.build, but sooner or later upstream is going to make X optional.
+# X? (
+DEPEND+="
+ >=gui-libs/gtk-4.0.0:4[X,introspection?]
+ >=x11-libs/libX11-1.7.0
+ >=x11-libs/libXcomposite-0.4
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ >=x11-libs/libXfixes-6
+ >=x11-libs/libXi-1.7.4
+ x11-libs/libXtst
+ x11-libs/libxkbfile
+ x11-misc/xkeyboard-config
+ >=x11-libs/libxkbcommon-0.4.3[X]
+ x11-libs/libXrender
+ >=x11-libs/libXrandr-1.5.0
+ x11-libs/libxcb:=
+ x11-libs/libXinerama
+ x11-libs/libXau
+"
+# )"
+
+RDEPEND="${DEPEND}
+ !<gui-libs/gtk-4.6.4:4
+"
+DEPEND="${DEPEND}
+ x11-base/xorg-proto
+ sysprof? ( >=dev-util/sysprof-common-3.38.0 )
+"
+BDEPEND="
+ dev-util/wayland-scanner
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? ( >=dev-util/gi-docgen-2021.1 )
+ test? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ >=dev-python/python-dbusmock-0.28[${PYTHON_USEDEP}]
+ ')
+ app-text/docbook-xml-dtd:4.5
+ x11-misc/xvfb-run
+ )
+ wayland? (
+ >=sys-kernel/linux-headers-4.4
+ x11-libs/libxcvt
+ )
+"
+
+PATCHES=(
+ "${WORKDIR}"/patches # Upstream branch up to commit 5f777c90b79a
+ "${FILESDIR}"/${PV}-fix-X-only.patch #914571, upstream #3046, !3471
+ "${FILESDIR}"/${PN}-43.0-Disable-anonymous-file-test.patch
+)
+
+python_check_deps() {
+ if use test; then
+ python_has_version ">=dev-python/python-dbusmock-0.28[${PYTHON_USEDEP}]"
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ # Mutter X11 renderer only supports gles2 and GLX, thus do NOT pass
+ #
+ # -Dopengl_libname=libOpenGL.so.0
+ #
+ # while we build the x11 renderer, as we currently enable gles2 only
+ # with USE=wayland and x11 renderer wouldn't find the needed GLX symbols
+ # in a configuration where wayland is disabled, as libOpenGL doesn't
+ # include them.
+ #
+ # See
+ # - https://bugs.gentoo.org/835786
+ # - https://forums.gentoo.org/viewtopic-p-8695669.html
+
+ --buildtype $(usex debug debug plain)
+ -Dopengl=true
+ $(meson_use wayland gles2)
+ #gles2_libname
+ -Degl=true
+ -Dglx=true
+ $(meson_use wayland)
+ $(meson_use wayland xwayland)
+ $(meson_use systemd)
+ $(meson_use wayland native_backend)
+ $(meson_use screencast remote_desktop)
+ $(meson_use gnome libgnome_desktop)
+ $(meson_use udev)
+ -Dudev_dir=$(get_udevdir)
+ $(meson_use input_devices_wacom libwacom)
+ -Dsound_player=true
+ -Dpango_ft2=true
+ -Dstartup_notification=true
+ -Dsm=true
+ $(meson_use introspection)
+ $(meson_use gtk-doc docs)
+ $(meson_use test cogl_tests)
+ $(meson_use wayland core_tests) # core tests require wayland; overall -Dtests option is honored on top, so no extra conditional needed
+ -Dnative_tests=false
+ $(meson_use test clutter_tests)
+ $(meson_use test tests)
+ -Dkvm_tests=false
+ -Dtty_tests=false
+ $(meson_use sysprof profiler)
+ -Dinstalled_tests=false
+
+ #verbose # Let upstream choose default for verbose mode
+ #xwayland_path
+ # TODO: relies on default settings, but in Gentoo we might have some more packages we want to give Xgrab access (mostly virtual managers and remote desktops)
+ #xwayland_grab_default_access_rules
+ )
+
+ if use wayland && use video_cards_nvidia; then
+ emesonargs+=(
+ -Degl_device=true
+ -Dwayland_eglstream=true
+ )
+ else
+ emesonargs+=(
+ -Degl_device=false
+ -Dwayland_eglstream=false
+ )
+ fi
+
+ meson_src_configure
+}
+
+src_test() {
+ # Reset variables to avoid issues from /etc/profile.d/flatpak.sh file
+ gnome2_environment_reset
+ export XDG_DATA_DIRS="${EPREFIX}"/usr/share
+ glib-compile-schemas "${BUILD_DIR}"/data
+ GSETTINGS_SCHEMA_DIR="${BUILD_DIR}"/data meson_src_test --setup=CI
+}
+
+pkg_postinst() {
+ use udev && udev_reload
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ use udev && udev_reload
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}