summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-03-19 21:32:10 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-03-19 21:41:11 +0100
commit61e97277f40a30dabeb87baaa0e320827eacc36f (patch)
tree3a34ca6e3b78223056f2986c0fd106e2c9757c72
parentdev-python/PyQt5-sip: add 4.19.15 (diff)
downloadgentoo-61e97277f40a30dabeb87baaa0e320827eacc36f.tar.gz
gentoo-61e97277f40a30dabeb87baaa0e320827eacc36f.tar.bz2
gentoo-61e97277f40a30dabeb87baaa0e320827eacc36f.zip
sys-apps/iproute2: Synced live ebuild.
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--sys-apps/iproute2/iproute2-9999.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/sys-apps/iproute2/iproute2-9999.ebuild b/sys-apps/iproute2/iproute2-9999.ebuild
index f9527624933e..c6720ff8aed3 100644
--- a/sys-apps/iproute2/iproute2-9999.ebuild
+++ b/sys-apps/iproute2/iproute2-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,11 +18,12 @@ HOMEPAGE="https://wiki.linuxfoundation.org/networking/iproute2"
LICENSE="GPL-2"
SLOT="0"
-IUSE="atm caps berkdb elf +iptables ipv6 minimal selinux"
+IUSE="atm berkdb caps elf +iptables ipv6 minimal selinux"
# We could make libmnl optional, but it's tiny, so eh
RDEPEND="
!net-misc/arpd
+ dev-libs/libbsd
!minimal? ( net-libs/libmnl )
caps? ( sys-libs/libcap )
elf? ( virtual/libelf )
@@ -39,18 +40,19 @@ DEPEND="
>=sys-devel/bison-2.4
sys-devel/flex
>=sys-kernel/linux-headers-3.16
+ virtual/pkgconfig
elibc_glibc? ( >=sys-libs/glibc-2.7 )
"
PATCHES=(
"${FILESDIR}"/${PN}-3.1.0-mtu.patch #291907
- "${FILESDIR}"/${PN}-4.17.0-configure-nomagic.patch # bug 643722
+ "${FILESDIR}"/${PN}-4.20.0-configure-nomagic.patch # bug 643722
)
src_prepare() {
if ! use ipv6 ; then
PATCHES+=(
- "${FILESDIR}"/${PN}-4.11.0-no-ipv6.patch #326849
+ "${FILESDIR}"/${PN}-4.20.0-no-ipv6.patch #326849
)
fi
@@ -61,7 +63,6 @@ src_prepare() {
-e "/^LIBDIR/s:=.*:=/$(get_libdir):" \
-e "s:-O2:${CFLAGS} ${CPPFLAGS}:" \
-e "/^HOSTCC/s:=.*:= $(tc-getBUILD_CC):" \
- -e "/^WFLAGS/s:-Werror::" \
-e "/^DBM_INCLUDE/s:=.*:=${T}:" \
Makefile || die
@@ -72,10 +73,12 @@ src_prepare() {
man/man8/ip-netns.8 || die
# build against system headers
- rm -r include/netinet #include/linux include/ip{,6}tables{,_common}.h include/libiptc
+ rm -r include/netinet || die #include/linux include/ip{,6}tables{,_common}.h include/libiptc
sed -i 's:TCPI_OPT_ECN_SEEN:16:' misc/ss.c || die
- use minimal && sed -i -e '/^SUBDIRS=/s:=.*:=lib tc ip:' Makefile
+ if use minimal ; then
+ sed -i -e '/^SUBDIRS=/s:=.*:=lib tc ip:' Makefile || die
+ fi
}
src_configure() {
@@ -146,7 +149,7 @@ src_install() {
sed -i '/linux\/netconf.h/d' "${ED%/}"/usr/include/libnetlink.h || die
if use berkdb ; then
- dodir /var/lib/arpd
+ keepdir /var/lib/arpd
# bug 47482, arpd doesn't need to be in /sbin
dodir /usr/bin
mv "${ED%/}"/sbin/arpd "${ED%/}"/usr/bin/ || die