summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-05-11 04:19:28 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-05-11 04:19:33 +0200
commit61e99a621f6a8e0ad3085838ec618102c906f6cb (patch)
tree63fed68460eef524b65c02940224acd9ec8dbeeb
parentmedia-video/vlc: bump to v3.0.14 (diff)
downloadgentoo-61e99a621f6a8e0ad3085838ec618102c906f6cb.tar.gz
gentoo-61e99a621f6a8e0ad3085838ec618102c906f6cb.tar.bz2
gentoo-61e99a621f6a8e0ad3085838ec618102c906f6cb.zip
media-video/vlc: always depend on media-libs/libvorbis
USE=tremor depends on libvorbis [Link 1] which is the root cause for bug 742551. However, VLC unconditionally uses libvorbis when found [Link 2], so we have to depend on media-libs/libvorbis all the time. Link 1: https://github.com/videolan/vlc/blob/ae406f9e6be4eb0b7d6b8db6edd51005d5af546f/modules/codec/Makefile.am#L312-L317 Link 2: https://github.com/videolan/vlc/blob/ae406f9e6be4eb0b7d6b8db6edd51005d5af546f/configure.ac#L2427-L2429 Closes: https://bugs.gentoo.org/742551 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--media-video/vlc/vlc-3.0.14.ebuild6
-rw-r--r--media-video/vlc/vlc-3.0.9999.ebuild6
-rw-r--r--media-video/vlc/vlc-9999.ebuild6
3 files changed, 9 insertions, 9 deletions
diff --git a/media-video/vlc/vlc-3.0.14.ebuild b/media-video/vlc/vlc-3.0.14.ebuild
index a706bd9e653e..935a496030c1 100644
--- a/media-video/vlc/vlc-3.0.14.ebuild
+++ b/media-video/vlc/vlc-3.0.14.ebuild
@@ -41,7 +41,7 @@ IUSE="a52 alsa aom archive aribsub bidi bluray cddb chromaprint chromecast
live lua macosx-notifications mad matroska modplug mp3 mpeg mtp musepack ncurses
nfs ogg omxil optimisememory opus png projectm pulseaudio +qt5 rdp
run-as-root samba sdl-image sftp shout sid skins soxr speex srt ssl svg taglib
- theora tremor truetype twolame udev upnp vaapi v4l vdpau vnc vorbis vpx wayland +X
+ theora tremor truetype twolame udev upnp vaapi v4l vdpau vnc vpx wayland +X
x264 x265 xml zeroconf zvbi cpu_flags_arm_neon cpu_flags_ppc_altivec cpu_flags_x86_mmx
cpu_flags_x86_sse
"
@@ -66,6 +66,7 @@ BDEPEND="
x86? ( dev-lang/yasm )
"
RDEPEND="
+ media-libs/libvorbis
net-dns/libidn:=
sys-libs/zlib[minizip]
virtual/libintl
@@ -208,7 +209,6 @@ RDEPEND="
vaapi? ( x11-libs/libva:=[drm,wayland?,X?] )
vdpau? ( x11-libs/libvdpau )
vnc? ( net-libs/libvncserver )
- vorbis? ( media-libs/libvorbis )
vpx? ( media-libs/libvpx:= )
wayland? (
>=dev-libs/wayland-1.15
@@ -294,6 +294,7 @@ src_configure() {
--enable-screen
--enable-vcd
--enable-vlc
+ --enable-vorbis
$(use_enable a52)
$(use_enable alsa)
$(use_enable aom)
@@ -394,7 +395,6 @@ src_configure() {
$(use_enable vaapi libva)
$(use_enable vdpau)
$(use_enable vnc)
- $(use_enable vorbis)
$(use_enable vpx)
$(use_enable wayland)
$(use_with X x)
diff --git a/media-video/vlc/vlc-3.0.9999.ebuild b/media-video/vlc/vlc-3.0.9999.ebuild
index 2017c3d83411..ae09b448136d 100644
--- a/media-video/vlc/vlc-3.0.9999.ebuild
+++ b/media-video/vlc/vlc-3.0.9999.ebuild
@@ -38,7 +38,7 @@ IUSE="a52 alsa aom archive aribsub bidi bluray cddb chromaprint chromecast dav1d
macosx-notifications mad matroska modplug mp3 mpeg mtp musepack ncurses nfs ogg
omxil optimisememory opus png projectm pulseaudio rdp run-as-root samba sdl-image
sftp shout sid skins soxr speex srt ssl svg taglib theora tremor truetype twolame
- udev upnp vaapi v4l vdpau vnc vorbis vpx wayland +X x264 x265 xml zeroconf zvbi
+ udev upnp vaapi v4l vdpau vnc vpx wayland +X x264 x265 xml zeroconf zvbi
cpu_flags_arm_neon cpu_flags_ppc_altivec cpu_flags_x86_mmx cpu_flags_x86_sse
"
REQUIRED_USE="
@@ -62,6 +62,7 @@ BDEPEND="
x86? ( dev-lang/yasm )
"
RDEPEND="
+ media-libs/libvorbis
net-dns/libidn:=
sys-libs/zlib[minizip]
virtual/libintl
@@ -204,7 +205,6 @@ RDEPEND="
vaapi? ( x11-libs/libva:=[drm,wayland?,X?] )
vdpau? ( x11-libs/libvdpau )
vnc? ( net-libs/libvncserver )
- vorbis? ( media-libs/libvorbis )
vpx? ( media-libs/libvpx:= )
wayland? (
>=dev-libs/wayland-1.15
@@ -290,6 +290,7 @@ src_configure() {
--enable-screen
--enable-vcd
--enable-vlc
+ --enable-vorbis
$(use_enable a52)
$(use_enable alsa)
$(use_enable aom)
@@ -390,7 +391,6 @@ src_configure() {
$(use_enable vaapi libva)
$(use_enable vdpau)
$(use_enable vnc)
- $(use_enable vorbis)
$(use_enable vpx)
$(use_enable wayland)
$(use_with X x)
diff --git a/media-video/vlc/vlc-9999.ebuild b/media-video/vlc/vlc-9999.ebuild
index 875389cc8ba9..d8edc34b878c 100644
--- a/media-video/vlc/vlc-9999.ebuild
+++ b/media-video/vlc/vlc-9999.ebuild
@@ -38,7 +38,7 @@ IUSE="a52 alsa aom archive aribsub bidi bluray cddb chromaprint chromecast dav1d
loudness lua macosx-notifications mad matroska modplug mp3 mpeg mtp musepack ncurses
nfs ogg omxil optimisememory opus png projectm pulseaudio rdp run-as-root samba
sdl-image sftp shout sid skins soxr speex srt ssl svg taglib theora tremor truetype
- twolame udev upnp vaapi v4l vdpau vnc vorbis vpx wayland +X x264 x265 xml zeroconf
+ twolame udev upnp vaapi v4l vdpau vnc vpx wayland +X x264 x265 xml zeroconf
zvbi cpu_flags_arm_neon cpu_flags_ppc_altivec cpu_flags_x86_mmx cpu_flags_x86_sse
"
REQUIRED_USE="
@@ -62,6 +62,7 @@ BDEPEND="
x86? ( dev-lang/yasm )
"
RDEPEND="
+ media-libs/libvorbis
net-dns/libidn:=
sys-libs/zlib[minizip]
virtual/libintl
@@ -206,7 +207,6 @@ RDEPEND="
vaapi? ( x11-libs/libva:=[drm,wayland?,X?] )
vdpau? ( x11-libs/libvdpau )
vnc? ( net-libs/libvncserver )
- vorbis? ( media-libs/libvorbis )
vpx? ( media-libs/libvpx:= )
wayland? (
>=dev-libs/wayland-1.15
@@ -292,6 +292,7 @@ src_configure() {
--enable-screen
--enable-vcd
--enable-vlc
+ --enable-vorbis
$(use_enable a52)
$(use_enable alsa)
$(use_enable aom)
@@ -394,7 +395,6 @@ src_configure() {
$(use_enable vaapi libva)
$(use_enable vdpau)
$(use_enable vnc)
- $(use_enable vorbis)
$(use_enable vpx)
$(use_enable wayland)
$(use_with X x)