summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-08-16 16:22:36 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-08-16 16:22:54 -0500
commit61fd48425430a79fdd1ab4baf9aad7cc2526e64f (patch)
treec09007185cf6ed66f9c772f895e7d6f6afd8d311
parentdev-python/mem_top: Drop to maintainer-needed (diff)
downloadgentoo-61fd48425430a79fdd1ab4baf9aad7cc2526e64f.tar.gz
gentoo-61fd48425430a79fdd1ab4baf9aad7cc2526e64f.tar.bz2
gentoo-61fd48425430a79fdd1ab4baf9aad7cc2526e64f.zip
app-admin/ansible: fix upgrading ansible from previous versions
Closes: https://bugs.gentoo.org/737434 Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-admin/ansible/ansible-2.10.0.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/app-admin/ansible/ansible-2.10.0.ebuild b/app-admin/ansible/ansible-2.10.0.ebuild
index 98ae9f94b8af..79e643cf99f7 100644
--- a/app-admin/ansible/ansible-2.10.0.ebuild
+++ b/app-admin/ansible/ansible-2.10.0.ebuild
@@ -49,6 +49,12 @@ DEPEND="
dev-vcs/git
)"
+python_compile() {
+ # disable version checks on upgrade
+ export ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+
python_compile_all() {
if use doc; then
cd docs/docsite || die