summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2017-01-27 11:03:08 -0500
committerIan Stakenvicius <axs@gentoo.org>2017-01-27 11:03:08 -0500
commit61fe4f891af6a622ebb4a3754f07ac5a54f5c629 (patch)
treed8071cd539ddcbffa09e522aac409af865998b9e
parentapp-portage/gentoolkit-dev: fix reponame for Prefix users (diff)
downloadgentoo-61fe4f891af6a622ebb4a3754f07ac5a54f5c629.tar.gz
gentoo-61fe4f891af6a622ebb4a3754f07ac5a54f5c629.tar.bz2
gentoo-61fe4f891af6a622ebb4a3754f07ac5a54f5c629.zip
www-client/firefox: adjust SHELL, other var specs on calls to emake
Aligned the use of forcing various variables on calls to emake, so that they are common across all current versions of firefox. This should address two bugs related to SHELL: bug 602370 and bug 600488 Package-Manager: portage-2.3.0
-rw-r--r--www-client/firefox/firefox-45.7.0.ebuild7
-rw-r--r--www-client/firefox/firefox-51.0.ebuild2
2 files changed, 4 insertions, 5 deletions
diff --git a/www-client/firefox/firefox-45.7.0.ebuild b/www-client/firefox/firefox-45.7.0.ebuild
index 6c62d9490f97..9ad87f2c1058 100644
--- a/www-client/firefox/firefox-45.7.0.ebuild
+++ b/www-client/firefox/firefox-45.7.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -220,6 +220,7 @@ src_configure() {
fi
# workaround for funky/broken upstream configure...
+ SHELL="${SHELL:-${EPREFIX%/}/bin/bash}" \
emake -f client.mk configure
}
@@ -245,11 +246,9 @@ src_compile() {
shopt -u nullglob
addpredict "${cards}"
- CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" \
MOZ_MAKE_FLAGS="${MAKEOPTS}" SHELL="${SHELL:-${EPREFIX%/}/bin/bash}" \
virtx emake -f client.mk profiledbuild || die "virtx emake failed"
else
- CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" \
MOZ_MAKE_FLAGS="${MAKEOPTS}" SHELL="${SHELL:-${EPREFIX%/}/bin/bash}" \
emake -f client.mk realbuild
fi
@@ -289,7 +288,7 @@ src_install() {
|| die
done
- MOZ_MAKE_FLAGS="${MAKEOPTS}" \
+ MOZ_MAKE_FLAGS="${MAKEOPTS}" SHELL="${SHELL:-${EPREFIX%/}/bin/bash}" \
emake DESTDIR="${D}" install
# Install language packs
diff --git a/www-client/firefox/firefox-51.0.ebuild b/www-client/firefox/firefox-51.0.ebuild
index 03a20ee9a5b5..f1f2b1c9674f 100644
--- a/www-client/firefox/firefox-51.0.ebuild
+++ b/www-client/firefox/firefox-51.0.ebuild
@@ -306,7 +306,7 @@ src_install() {
|| die
done
- MOZ_MAKE_FLAGS="${MAKEOPTS}" \
+ MOZ_MAKE_FLAGS="${MAKEOPTS}" SHELL="${SHELL:-${EPREFIX%/}/bin/bash}" \
emake DESTDIR="${D}" install
# Install language packs