summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-06-26 03:25:55 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-06-26 04:16:43 +0000
commit6210899ddc89d87f07c32711f65d2dfaebd42947 (patch)
tree9a27408a998b1a95a619e13f18122d52a1336e7e
parentdev-python/pytest-mpl: (diff)
downloadgentoo-6210899d.tar.gz
gentoo-6210899d.tar.bz2
gentoo-6210899d.zip
dev-python/astropy: version bump
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--dev-python/astropy/Manifest2
-rw-r--r--dev-python/astropy/astropy-1.3.3.ebuild (renamed from dev-python/astropy/astropy-1.3.ebuild)20
-rw-r--r--dev-python/astropy/files/astropy-1.3.3-external-python-pkgs.patch196
-rw-r--r--dev-python/astropy/files/astropy-1.3.3-mark-known-failures.patch (renamed from dev-python/astropy/files/astropy-1.3-mark-known-failures.patch)0
4 files changed, 206 insertions, 12 deletions
diff --git a/dev-python/astropy/Manifest b/dev-python/astropy/Manifest
index fb18d25d266e..93eb031730c1 100644
--- a/dev-python/astropy/Manifest
+++ b/dev-python/astropy/Manifest
@@ -1,2 +1,2 @@
DIST astropy-1.2.1.tar.gz 8179665 SHA256 0d7ef702166f26fed239b59fc12edcd5243ca5bf562a36202fd8c6b0270d6e48 SHA512 2ef37537a4c6b2ec50a1d898f600978475c9c5d2cb66ba19d06782656e9ddcb4aa6a8e53217e318448cedac45dac0dce0d8cc2fe94cddc15ebb306b3b0794595 WHIRLPOOL d37374f23a0121fdc92fa572facc248f0a571dacb8edcf1a9d0987d6a40287de199262ec01f654bd6ea5aece826e5588d2869558152adffe9ab490fa46f2e36d
-DIST astropy-1.3.tar.gz 8372366 SHA256 49de3e86482abe24e3cd02c4a30a469ee4b928d5b46ea5f70fa605ff6f9c6d38 SHA512 1dd667af78be568bd4719d273d432881d7dea03725deb24a045726b315f8e5cd8afac3f6f925867b05c4c7924cd71d7e7d6ae15985a95c7fcc4421e52273983b WHIRLPOOL 2913c195989c2af0a58ab5e675bd41607bb28273265c0a502c8b1d33925994f9127c9a03058b55aabc1b3a8c594e89ddbd2d5fc38c42dd4723998bad01c7bd45
+DIST astropy-1.3.3.tar.gz 8427036 SHA256 ed093e033fcbee5a3ec122420c3376f8a80f74663214560727d3defe82170a99 SHA512 15956d488a390ab3b4091146bffe6f192f22e7598d00e302c2bcf0ec9728911f48bef3ee4c71d331f58e57aec86292421d27f915ea16027a7f62c5d43f6a12e5 WHIRLPOOL a9246b1ba56ecda5eec42e89998f18da4987f611d1154ba8ef5d3480d398fd77c0fdad6c15614885ae722454b9c284b9281ee926fed0f39c314864a015bf658f
diff --git a/dev-python/astropy/astropy-1.3.ebuild b/dev-python/astropy/astropy-1.3.3.ebuild
index 7fa95760a886..923ff494b4ba 100644
--- a/dev-python/astropy/astropy-1.3.ebuild
+++ b/dev-python/astropy/astropy-1.3.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
inherit distutils-r1 xdg-utils
@@ -24,10 +24,10 @@ RDEPEND="
dev-python/six[${PYTHON_USEDEP}]
>=sci-astronomy/erfa-1.3:0=
>=sci-astronomy/wcslib-5:0=
- sci-libs/cfitsio:0=
+ >=sci-libs/cfitsio-3.410:0=
sys-libs/zlib:0="
DEPEND="${RDEPEND}
- >=dev-python/astropy-helpers-1.1[${PYTHON_USEDEP}]
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
dev-python/cython[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
virtual/pkgconfig
@@ -37,25 +37,23 @@ DEPEND="${RDEPEND}
dev-python/h5py[${PYTHON_USEDEP}]
dev-python/jplephem[${PYTHON_USEDEP}]
dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},jpeg]
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/sphinx-gallery[${PYTHON_USEDEP}]
- dev-python/wcsaxes[${PYTHON_USEDEP}]
sci-libs/scipy[${PYTHON_USEDEP}]
)
test? (
dev-libs/libxml2[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},jpeg]
dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-mpl[${PYTHON_USEDEP}]
dev-python/h5py[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
sci-libs/scipy[${PYTHON_USEDEP}]
)"
PATCHES=(
- "${FILESDIR}"/${PN}-1.0.4-system-six.patch
- "${FILESDIR}"/${PN}-1.0.4-system-configobj.patch
- "${FILESDIR}"/${PN}-1.3-mark-known-failures.patch
- "${FILESDIR}"/${PN}-1.2.1-cfitsio-338.patch
+ "${FILESDIR}"/${PN}-1.3.3-mark-known-failures.patch
+ "${FILESDIR}"/${PN}-1.3.3-external-python-pkgs.patch
)
python_prepare_all() {
diff --git a/dev-python/astropy/files/astropy-1.3.3-external-python-pkgs.patch b/dev-python/astropy/files/astropy-1.3.3-external-python-pkgs.patch
new file mode 100644
index 000000000000..417960940603
--- /dev/null
+++ b/dev-python/astropy/files/astropy-1.3.3-external-python-pkgs.patch
@@ -0,0 +1,196 @@
+From: Ole Streicher <olebole@debian.org>
+Date: Thu, 12 Jan 2017 11:37:47 +0100
+Subject: Use external python modules instead of convenience copies
+
+---
+ astropy/coordinates/angle_utilities.py | 2 +-
+ astropy/extern/configobj.py | 5 ++++-
+ astropy/extern/six.py | 2 +-
+ astropy/table/jsviewer.py | 14 ++++++++------
+ astropy/table/tests/test_jsviewer.py | 6 +++---
+ astropy/tests/helper.py | 2 +-
+ astropy/units/format/cds.py | 4 ++--
+ astropy/units/format/generic.py | 4 ++--
+ astropy/units/format/ogip.py | 4 ++--
+ 9 files changed, 24 insertions(+), 19 deletions(-)
+
+diff --git a/astropy/coordinates/angle_utilities.py b/astropy/coordinates/angle_utilities.py
+index cfa894e..bb8fb7d 100644
+--- a/astropy/coordinates/angle_utilities.py
++++ b/astropy/coordinates/angle_utilities.py
+@@ -64,7 +64,7 @@ class _AngleParser(object):
+
+ @classmethod
+ def _make_parser(cls):
+- from ..extern.ply import lex, yacc
++ from ply import lex, yacc
+
+ # List of token names.
+ tokens = (
+diff --git a/astropy/extern/configobj.py b/astropy/extern/configobj.py
+index 8d1bd8c..e3bb0e0 100644
+--- a/astropy/extern/configobj.py
++++ b/astropy/extern/configobj.py
+@@ -7,5 +7,8 @@ currently installed version of python.
+ Also, this should actually never actually show up as a docstring, because
+ it should get overwritten by the appropriate configobj docstring.
+ """
++from __future__ import absolute_import
++import validate
++import configobj
++
+
+-from .configobj import configobj, validate, __doc__
+diff --git a/astropy/extern/six.py b/astropy/extern/six.py
+index 5398fc0..fb3a30c 100644
+--- a/astropy/extern/six.py
++++ b/astropy/extern/six.py
+@@ -13,7 +13,7 @@ _SIX_MIN_VERSION = StrictVersion('1.10.0')
+ # Update this to prevent Astropy from using its bundled copy of six
+ # (but only if some other version of at least _SIX_MIN_VERSION can
+ # be provided)
+-_SIX_SEARCH_PATH = ['astropy.extern.bundled.six', 'six']
++_SIX_SEARCH_PATH = ['six']
+
+
+ def _find_module(name, path=None):
+diff --git a/astropy/table/jsviewer.py b/astropy/table/jsviewer.py
+index d0cc380..9f686ea 100644
+--- a/astropy/table/jsviewer.py
++++ b/astropy/table/jsviewer.py
+@@ -30,8 +30,8 @@ class Conf(_config.ConfigNamespace):
+ conf = Conf()
+
+
+-EXTERN_JS_DIR = abspath(join(dirname(extern.__file__), 'js'))
+-EXTERN_CSS_DIR = abspath(join(dirname(extern.__file__), 'css'))
++EXTERN_JS_DIR = '/usr/share/javascript'
++EXTERN_CSS_DIR = EXTERN_JS_DIR
+
+ _SORTING_SCRIPT_PART_1 = """
+ var astropy_sort_num = function(a, b) {{
+@@ -134,22 +134,24 @@ class JSViewer(object):
+ @property
+ def jquery_urls(self):
+ if self._use_local_files:
+- return ['file://' + join(EXTERN_JS_DIR, 'jquery-3.1.1.min.js'),
+- 'file://' + join(EXTERN_JS_DIR, 'jquery.dataTables.min.js')]
++ return ['file://' + join(EXTERN_JS_DIR, 'jquery', 'jquery.min.js'),
++ 'file://' + join(EXTERN_JS_DIR, 'jquery-datatables',
++ 'jquery.dataTables.min.js')]
+ else:
+ return [conf.jquery_url, conf.datatables_url]
+
+ @property
+ def css_urls(self):
+ if self._use_local_files:
+- return ['file://' + join(EXTERN_CSS_DIR,
++ return ['file://' + join(EXTERN_CSS_DIR, 'jquery-datatables', 'css',
+ 'jquery.dataTables.css')]
+ else:
+ return conf.css_urls
+
+ def _jstable_file(self):
+ if self._use_local_files:
+- return 'file://' + join(EXTERN_JS_DIR, 'jquery.dataTables.min')
++ return 'file://' + join(EXTERN_JS_DIR, 'jquery-datatables',
++ 'jquery.dataTables.min')
+ else:
+ return conf.datatables_url[:-3]
+
+diff --git a/astropy/table/tests/test_jsviewer.py b/astropy/table/tests/test_jsviewer.py
+index 6a8b033..5018bd4 100644
+--- a/astropy/table/tests/test_jsviewer.py
++++ b/astropy/table/tests/test_jsviewer.py
+@@ -145,9 +145,9 @@ def test_write_jsviewer_local(tmpdir):
+ table_id='test',
+ length='50',
+ display_length='10, 25, 50, 100, 500, 1000',
+- datatables_css_url='file://' + join(EXTERN_DIR, 'css', 'jquery.dataTables.css'),
+- datatables_js_url='file://' + join(EXTERN_DIR, 'js', 'jquery.dataTables.min.js'),
+- jquery_url='file://' + join(EXTERN_DIR, 'js', 'jquery-3.1.1.min.js')
++ datatables_css_url='file:///usr/share/javascript/jquery-datatables/css/jquery.dataTables.css',
++ datatables_js_url='file:///usr/share/javascript/jquery-datatables/jquery.dataTables.min.js',
++ jquery_url='file:///usr/share/javascript/jquery/jquery.min.js'
+ )
+ with open(tmpfile) as f:
+ assert f.read().strip() == ref.strip()
+diff --git a/astropy/tests/helper.py b/astropy/tests/helper.py
+index 9e88d1f..94bd40a 100644
+--- a/astropy/tests/helper.py
++++ b/astropy/tests/helper.py
+@@ -40,7 +40,7 @@ __all__ = ['raises', 'enable_deprecations_as_exceptions', 'remote_data',
+ 'pickle_protocol', 'generic_recursive_equality_test']
+
+
+-if os.environ.get('ASTROPY_USE_SYSTEM_PYTEST') or '_pytest' in sys.modules:
++if True:
+ import pytest
+
+ else:
+diff --git a/astropy/units/format/cds.py b/astropy/units/format/cds.py
+index e40c1cf..0d5e033 100644
+--- a/astropy/units/format/cds.py
++++ b/astropy/units/format/cds.py
+@@ -78,7 +78,7 @@ class CDS(Base):
+
+ @classmethod
+ def _make_lexer(cls):
+- from ...extern.ply import lex
++ from ply import lex
+
+ tokens = cls._tokens
+
+@@ -142,7 +142,7 @@ class CDS(Base):
+ <https://bitbucket.org/nxg/unity/>`_.
+ """
+
+- from ...extern.ply import yacc
++ from ply import yacc
+
+ tokens = cls._tokens
+
+diff --git a/astropy/units/format/generic.py b/astropy/units/format/generic.py
+index 6f1d0e6..8c12a2d 100644
+--- a/astropy/units/format/generic.py
++++ b/astropy/units/format/generic.py
+@@ -102,7 +102,7 @@ class Generic(Base):
+
+ @classmethod
+ def _make_lexer(cls):
+- from ...extern.ply import lex
++ from ply import lex
+
+ tokens = cls._tokens
+
+@@ -177,7 +177,7 @@ class Generic(Base):
+ formats, the only difference being the set of available unit
+ strings.
+ """
+- from ...extern.ply import yacc
++ from ply import yacc
+
+ tokens = cls._tokens
+
+diff --git a/astropy/units/format/ogip.py b/astropy/units/format/ogip.py
+index e429407..e80e35a 100644
+--- a/astropy/units/format/ogip.py
++++ b/astropy/units/format/ogip.py
+@@ -110,7 +110,7 @@ class OGIP(generic.Generic):
+
+ @classmethod
+ def _make_lexer(cls):
+- from ...extern.ply import lex
++ from ply import lex
+
+ tokens = cls._tokens
+
+@@ -180,7 +180,7 @@ class OGIP(generic.Generic):
+ <https://bitbucket.org/nxg/unity/>`_.
+ """
+
+- from ...extern.ply import yacc
++ from ply import yacc
+
+ tokens = cls._tokens
+
diff --git a/dev-python/astropy/files/astropy-1.3-mark-known-failures.patch b/dev-python/astropy/files/astropy-1.3.3-mark-known-failures.patch
index 1a30bc1d10ab..1a30bc1d10ab 100644
--- a/dev-python/astropy/files/astropy-1.3-mark-known-failures.patch
+++ b/dev-python/astropy/files/astropy-1.3.3-mark-known-failures.patch