summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-04-29 01:16:21 +0200
committerPacho Ramos <pacho@gentoo.org>2023-04-29 01:17:09 +0200
commit6226f613d81c0226e7bfd79e0462c36485c18072 (patch)
treed97deacb741e713879b6b187a04ea1159ad72f75
parentdev-util/idea-community: drop 2023.1 (diff)
downloadgentoo-6226f613.tar.gz
gentoo-6226f613.tar.bz2
gentoo-6226f613.zip
games-puzzle/pingus: Honour arguments in the wrapper
And respect AR variabke Closes: https://bugs.gentoo.org/782394 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--games-puzzle/pingus/files/pingus-0.7.6-echo-e.patch4
-rw-r--r--games-puzzle/pingus/pingus-0.7.6-r5.ebuild (renamed from games-puzzle/pingus/pingus-0.7.6-r4.ebuild)1
2 files changed, 3 insertions, 2 deletions
diff --git a/games-puzzle/pingus/files/pingus-0.7.6-echo-e.patch b/games-puzzle/pingus/files/pingus-0.7.6-echo-e.patch
index ab772d8c72e9..ac329c0dd58d 100644
--- a/games-puzzle/pingus/files/pingus-0.7.6-echo-e.patch
+++ b/games-puzzle/pingus/files/pingus-0.7.6-echo-e.patch
@@ -1,5 +1,5 @@
# Work around Gentoo's crippled dash
-
+# Also add "$@" to accept options
--- pingus-0.7.6/Makefile
+++ pingus-0.7.6/Makefile
@@ -39,7 +39,7 @@
@@ -7,7 +7,7 @@
install -D build/pingus "$(DESTDIR)$(BINDIR)/pingus.bin"
- echo -e "#!/bin/sh\nexec \"$(BINDIR)/pingus.bin\" --datadir \"$(DATADIR)\"" > "$(DESTDIR)$(BINDIR)/pingus"
-+ printf '%s\n%s' "#!/bin/sh" "exec \"$(BINDIR)/pingus.bin\" --datadir \"$(DATADIR)\"" > "$(DESTDIR)$(BINDIR)/pingus"
++ printf '%s\n%s' "#!/bin/sh" "exec \"$(BINDIR)/pingus.bin\" --datadir \"$(DATADIR)\" \"\$$@\"" > "$(DESTDIR)$(BINDIR)/pingus"
chmod 755 "$(DESTDIR)$(BINDIR)/pingus"
install-data:
diff --git a/games-puzzle/pingus/pingus-0.7.6-r4.ebuild b/games-puzzle/pingus/pingus-0.7.6-r5.ebuild
index 99a5e62da97e..b9cf5c7b0a22 100644
--- a/games-puzzle/pingus/pingus-0.7.6-r4.ebuild
+++ b/games-puzzle/pingus/pingus-0.7.6-r5.ebuild
@@ -40,6 +40,7 @@ PATCHES=(
src_compile() {
strip-flags
escons \
+ AR="$(tc-getAR)" \
CXX="$(tc-getCXX)" \
CCFLAGS="${CXXFLAGS}" \
LINKFLAGS="${LDFLAGS}" \