summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-10-03 18:28:06 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-10-03 20:09:23 +0200
commit622a4b3334ffdf001040b665900f61b72023e57e (patch)
treefc3f963e71b6e7ec5d92e3af84d477469a37fea4
parentwww-client/firefox: synchronize with www-client/firefox-bin (diff)
downloadgentoo-622a4b33.tar.gz
gentoo-622a4b33.tar.bz2
gentoo-622a4b33.zip
mail-client/thunderbird: synchronize with www-client/firefox
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--mail-client/thunderbird/thunderbird-78.3.1.ebuild17
1 files changed, 11 insertions, 6 deletions
diff --git a/mail-client/thunderbird/thunderbird-78.3.1.ebuild b/mail-client/thunderbird/thunderbird-78.3.1.ebuild
index 2414310d4eae..e94b6cb2500b 100644
--- a/mail-client/thunderbird/thunderbird-78.3.1.ebuild
+++ b/mail-client/thunderbird/thunderbird-78.3.1.ebuild
@@ -26,21 +26,24 @@ if [[ -n ${MOZ_ESR} ]] ; then
MOZ_PV="${MOZ_PV}esr"
fi
+MOZ_PN="${PN%-bin}"
+MOZ_P="${MOZ_PN}-${MOZ_PV}"
+
inherit autotools check-reqs desktop flag-o-matic gnome2-utils llvm \
multiprocessing pax-utils python-any-r1 toolchain-funcs \
virtualx xdg
-MOZ_SRC_BASE_URI="https://archive.mozilla.org/pub/${PN}/releases/${MOZ_PV}"
+MOZ_SRC_BASE_URI="https://archive.mozilla.org/pub/${MOZ_PN}/releases/${MOZ_PV}"
if [[ ${PV} == *_rc* ]] ; then
- MOZ_SRC_BASE_URI="https://archive.mozilla.org/pub/${PN}/candidates/${MOZ_PV}-candidates/build${PV##*_rc}"
+ MOZ_SRC_BASE_URI="https://archive.mozilla.org/pub/${MOZ_PN}/candidates/${MOZ_PV}-candidates/build${PV##*_rc}"
fi
PATCH_URIS=(
https://dev.gentoo.org/~{axs,polynomial-c,whissi}/mozilla/patchsets/${FIREFOX_PATCHSET}
)
-SRC_URI="${MOZ_SRC_BASE_URI}/source/${PN}-${MOZ_PV}.source.tar.xz
+SRC_URI="${MOZ_SRC_BASE_URI}/source/${MOZ_P}.source.tar.xz
${PATCH_URIS[@]}"
DESCRIPTION="Thunderbird Mail Client"
@@ -234,7 +237,7 @@ mozilla_set_globals() {
fi
SRC_URI+=" l10n_${xflag/[_@]/-}? ("
- SRC_URI+=" ${MOZ_SRC_BASE_URI}/linux-x86_64/xpi/${lang}.xpi -> ${PN}-${MOZ_PV}-${lang}.xpi"
+ SRC_URI+=" ${MOZ_SRC_BASE_URI}/linux-x86_64/xpi/${lang}.xpi -> ${MOZ_P}-${lang}.xpi"
SRC_URI+=" )"
IUSE+=" l10n_${xflag/[_@]/-}"
done
@@ -867,7 +870,7 @@ src_install() {
local desktop_file="${FILESDIR}/icon/${PN}-r2.desktop"
local display_protocols="auto X11"
local icon="${PN}"
- local name="Mozilla ${PN^}"
+ local name="Mozilla ${MOZ_PN^}"
local use_wayland="false"
if use wayland ; then
@@ -917,7 +920,7 @@ src_install() {
done
# Install generic wrapper script
- rm "${ED}/usr/bin/${PN}" || die
+ [[ -f "${ED}/usr/bin/${PN}" ]] && rm "${ED}/usr/bin/${PN}"
newbin "${FILESDIR}/${PN}.sh" ${PN}
# Update wrapper
@@ -931,6 +934,8 @@ src_install() {
sed -i \
-e "s:@PREFIX@:${EPREFIX}/usr:" \
+ -e "s:@MOZ_FIVE_HOME@:${MOZILLA_FIVE_HOME}:" \
+ -e "s:@APULSELIB_DIR@:${apulselib}:" \
-e "s:@DEFAULT_WAYLAND@:${use_wayland}:" \
"${wrapper}" \
|| die