summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-07-24 15:12:35 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-07-24 15:25:57 -0500
commit624e5035ed4438a84295cf4003443f9f031559f9 (patch)
treea8fd94e18dcc66daff1b1cf7d2b55b291f70b4e9
parentsci-libs/pastix: Drop ~alpha keywords, bug #764023 (diff)
downloadgentoo-624e5035ed4438a84295cf4003443f9f031559f9.tar.gz
gentoo-624e5035ed4438a84295cf4003443f9f031559f9.tar.bz2
gentoo-624e5035ed4438a84295cf4003443f9f031559f9.zip
app-emulation/diskimage-builder: 3.13.0 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-3.13.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index fd41ca2328ab..9bab501dff12 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1,2 +1,3 @@
DIST diskimage-builder-3.11.0.tar.gz 475123 BLAKE2B 2d286193c99077b943ddc2342871878d78380c27b247cca895d14e9ca1ca69c3d260fe0061e9f09a80156cee327234ce0a8c129f2008422d0db1bd736175f490 SHA512 083a3dff0ec32cd35cb5a95f25b115778aa4b74ab47796c13ac007fa6af5940140117eb4c2b5f44674316f65b0c0b53b6e077787e8018f6d7735906d333d2da0
DIST diskimage-builder-3.12.0.tar.gz 477540 BLAKE2B 9facf1d6ef9a38b960b7bcc8ee035d8f7ae6c5189d1de25e335d68a6e8389be0ab0f3b787e5d5112ee7ef508b583d1df612ca75149659f78685a2fdf6dee21a7 SHA512 edec229023673c48a3176b315c9d84067b4e7b4a30843839722a7ce300f898d92ee5f5146b6d92f2eda692bada4370b32f1b19f3b929a379b3e604b6e7ce29d6
+DIST diskimage-builder-3.13.0.tar.gz 494027 BLAKE2B 27a88118d688018a5f842e0d483e3128b0715cdc21f33308de61ea5077ad1b824738363ae066463e84e7e3821a36085afc9985fde74883ab040c67a25073e5c0 SHA512 7b099811021f199ed0680e2dc4db6302b05dc6adf95ac96e890501cf92727dc319fbf96f9c68a8b9bca26ba54d7ff5e6a67f036a9d86a3ad1752d5cc4a8edbaf
diff --git a/app-emulation/diskimage-builder/diskimage-builder-3.13.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-3.13.0.ebuild
new file mode 100644
index 000000000000..92726b9c7654
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-3.13.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"