summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-11-30 15:56:32 +0100
committerJeroen Roovers <jer@gentoo.org>2019-11-30 15:59:31 +0100
commit625a5bcc3e463c5f266e17ab5aab98b94e79ee6b (patch)
treef272f54e82b3909f1510b6cc49b6b2fedb1cba25
parentmedia-libs/bcg729: Version 4.3.0_beta (diff)
downloadgentoo-625a5bcc3e463c5f266e17ab5aab98b94e79ee6b.tar.gz
gentoo-625a5bcc3e463c5f266e17ab5aab98b94e79ee6b.tar.bz2
gentoo-625a5bcc3e463c5f266e17ab5aab98b94e79ee6b.zip
media-libs/bcg729: Update live ebuild
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--media-libs/bcg729/bcg729-999999.ebuild19
1 files changed, 14 insertions, 5 deletions
diff --git a/media-libs/bcg729/bcg729-999999.ebuild b/media-libs/bcg729/bcg729-999999.ebuild
index 961164ae6e95..aabbb6a8fda8 100644
--- a/media-libs/bcg729/bcg729-999999.ebuild
+++ b/media-libs/bcg729/bcg729-999999.ebuild
@@ -2,23 +2,32 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit git-r3 cmake-multilib
+inherit cmake-utils git-r3
DESCRIPTION="encoder and decoder of the ITU G729 Annex A/B speech codec"
HOMEPAGE="https://github.com/BelledonneCommunications/bcg729"
-EGIT_REPO_URI="${HOMEPAGE}"
+EGIT_REPO_URI="https://github.com/BelledonneCommunications/bcg729"
-LICENSE="GPL-3"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
IUSE="static-libs"
RDEPEND="
!media-plugins/mediastreamer-bcg729
"
+S=${WORKDIR}/${P/_/-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.0_beta-cmake-build.patch
+)
-multilib_src_configure() {
- local mycmakeargs+=(
+src_configure() {
+ mycmakeargs=(
-DENABLE_STATIC=$(usex static-libs)
)
cmake-utils_src_configure
}
+
+src_install() {
+ cmake-utils_src_install
+ find "${ED}" -name '*.la' -delete || die
+}