summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-31 11:42:50 +0100
committerSam James <sam@gentoo.org>2022-05-31 11:43:40 +0100
commit625ace424a77a34f9c8c1ec44e311b7d1b685ef8 (patch)
treee1f5562ff6d81f4a7989a0d7373eb772101257a0
parentapp-misc/gcalcli: enable py3.10 and disable py3.7 (diff)
downloadgentoo-625ace42.tar.gz
gentoo-625ace42.tar.bz2
gentoo-625ace42.zip
app-misc/gcalcli: add 4.3.0
Bug: https://bugs.gentoo.org/845498 Closes: https://bugs.gentoo.org/813969 Closes: https://bugs.gentoo.org/800635 Closes: https://bugs.gentoo.org/763327 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-misc/gcalcli/Manifest1
-rw-r--r--app-misc/gcalcli/gcalcli-4.3.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-misc/gcalcli/Manifest b/app-misc/gcalcli/Manifest
index 890a6a8fcad7..dfb0bfe442ed 100644
--- a/app-misc/gcalcli/Manifest
+++ b/app-misc/gcalcli/Manifest
@@ -1 +1,2 @@
DIST gcalcli-4.2.0.tar.gz 1701050 BLAKE2B a0e310097cdb740ac873049d19d21dc8698afe61c919fd082258864e7170f5ca42a55b4eb211cfa9ecd9b2bef63f3e107839a4e3cad9ec2c278a8529f58ac33c SHA512 2dd39a62e3fd81753f30b77be196476ef366cb6914e62c5de82ab946b7159751a5cbf246aa54eaed1fb6adfef7dbba785d10e29571a454b627b7ff45b52375d6
+DIST gcalcli-4.3.0.gh.tar.gz 1702967 BLAKE2B 04623e2140769a56c28a03e315f8ef1e9fe51571f2e46d2529e1fca062c85de251c6adc631057df228494d449b93564e9fe71998f8702ed87dbc5ec5e7803bbd SHA512 ea8680be5351d7b18206ea7b010d49a8c87cbafc9d754cf7f47587a09228c45b29f76d29644770a881cb7c750a1e0e59262b7875eca77aee5bc2476e456b807e
diff --git a/app-misc/gcalcli/gcalcli-4.3.0.ebuild b/app-misc/gcalcli/gcalcli-4.3.0.ebuild
new file mode 100644
index 000000000000..b0ff10b2fe22
--- /dev/null
+++ b/app-misc/gcalcli/gcalcli-4.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Google Calendar Command Line Interface"
+HOMEPAGE="https://github.com/insanum/gcalcli"
+SRC_URI="https://github.com/insanum/gcalcli/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/google-api-python-client-1.5.3[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/parsedatetime[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-gflags[${PYTHON_USEDEP}]
+ dev-python/vobject[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_install() {
+ dodoc -r ChangeLog README.md docs
+ distutils-r1_src_install
+}