summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-20 06:43:34 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-20 06:43:34 +0200
commit626cb3d86a74ee3b847c7f6dcfbf6bc5033f0c21 (patch)
tree002ad2e70b9eb1bda7b29700a99a91d59909ab2e
parentdev-python/pytest-localftpserver: Bump to 1.3.2 (diff)
downloadgentoo-626cb3d86a74ee3b847c7f6dcfbf6bc5033f0c21.tar.gz
gentoo-626cb3d86a74ee3b847c7f6dcfbf6bc5033f0c21.tar.bz2
gentoo-626cb3d86a74ee3b847c7f6dcfbf6bc5033f0c21.zip
dev-python/pytest-asyncio: Bump to 0.23.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-asyncio/Manifest1
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.23.7.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index 607d9e7c19a0..50814f4c8fda 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1 +1,2 @@
DIST pytest-asyncio-0.23.6.tar.gz 46203 BLAKE2B 37dd3cafa2c77b0dd04a6f406e9e83705b31a98eb058fef02ad6d917cb291874dac0388a129bce5d80954fe8dd0a28fbe9e2b94dabc2ff59a1a055154b908cce SHA512 24ec7fef2f1db744c743c4da651106320d02e8a83af0a238f6335ef669751e541b7fa787fd007fd7208f1837c1cb684acdecd66ee5e022501a7aad97649fdfbe
+DIST pytest_asyncio-0.23.7.tar.gz 46296 BLAKE2B afcdba0928f07e91ed68f54de2c1241fec784f164e3d5edb09908b913536edadbba7c90a73a8c843715da4567b18cc27929f31c6d0c2be3940e6ecc23abcc43c SHA512 d7164b060c1d0aa7999537e5681d2153662d49ec94e056da93b4cb2ba3dd0e3e5e4a68691c15b920c8e0ced03a4256620da600a33bcfa76b1adfa7ee66cd8de0
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.23.7.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.23.7.ebuild
new file mode 100644
index 000000000000..ccbee1a2f1c6
--- /dev/null
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.23.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Library for testing asyncio code with pytest"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-asyncio/
+ https://pypi.org/project/pytest-asyncio/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on precise warning counts
+ tests/hypothesis/test_base.py::test_can_use_explicit_event_loop_fixture
+ tests/modes/test_legacy_mode.py
+ tests/modes/test_strict_mode.py::test_strict_mode_ignores_unmarked_fixture
+ tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_fixture_leaves_loop_unclosed
+ tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_test_leaves_loop_unclosed
+ tests/test_pytest_min_version_warning.py
+ tests/trio/test_fixtures.py::test_strict_mode_ignores_trio_fixtures
+
+ # TODO
+ tests/test_is_async_test.py::test_returns_false_for_unmarked_coroutine_item_in_strict_mode
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_asyncio.plugin,_hypothesis_pytestplugin
+ epytest
+}