summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-09 15:08:30 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-09 15:12:01 +0200
commit628b38d48c9f457268882813990470026d835c81 (patch)
tree855c8735e0fe824404e2237d15acc7edc9202596
parentdev-python/unittest-mixins: Enable py3.13 (diff)
downloadgentoo-628b38d48c9f457268882813990470026d835c81.tar.gz
gentoo-628b38d48c9f457268882813990470026d835c81.tar.bz2
gentoo-628b38d48c9f457268882813990470026d835c81.zip
dev-python/genty: Remove dev-python/mock dep
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/genty/genty-1.3.2-r3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/genty/genty-1.3.2-r3.ebuild b/dev-python/genty/genty-1.3.2-r3.ebuild
new file mode 100644
index 000000000000..dc0d5d5866ae
--- /dev/null
+++ b/dev-python/genty/genty-1.3.2-r3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Allows you to run a test with multiple data sets"
+HOMEPAGE="
+ https://pypi.org/project/genty/
+ https://github.com/box/genty/
+"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ sed -i -e 's:from mock:from unittest.mock:' test/test_genty.py || die
+}