summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-09-20 17:59:46 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-09-20 18:26:59 +0200
commit62a65af046780589d1768419d54e1250c98076aa (patch)
tree31be796741c43a6f606d321aedc578c7cb4f7b85
parentapp-editors/emacs: Make the small-ja-dic flag actually work (diff)
downloadgentoo-62a65af046780589d1768419d54e1250c98076aa.tar.gz
gentoo-62a65af046780589d1768419d54e1250c98076aa.tar.bz2
gentoo-62a65af046780589d1768419d54e1250c98076aa.zip
games-emulation/ppsspp: bump to 1.16.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--games-emulation/ppsspp/Manifest1
-rw-r--r--games-emulation/ppsspp/ppsspp-1.16.2.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/games-emulation/ppsspp/Manifest b/games-emulation/ppsspp/Manifest
index bb22be75c19a..5465a792206e 100644
--- a/games-emulation/ppsspp/Manifest
+++ b/games-emulation/ppsspp/Manifest
@@ -1,3 +1,4 @@
DIST ppsspp-1.15.4.tar.xz 51947468 BLAKE2B c6a5e621b02556b791ec41389f17dede63811c87ff628b8f1304ac950071b365ecc9be05f4042e4e3b81e77f5a14b6931577f08b0174fec821350a1d7eca4d6a SHA512 9d2c140b0d633e5ca6191aaf276b7e4f6d029f29d1313a45fb78ee3879fec09f57d816604c51474ab6fe9cde713787d5769e87466d3c3015fe6a9b195ff198d2
DIST ppsspp-1.16.1.tar.xz 50656184 BLAKE2B ec32ab91334889251eded8e72a1229af2566bb5c423236c8cbb6206d48e5aab625aa430b99e55cedd582525dcda9bbf8f21336ff468a1b57fa618999badd0628 SHA512 ad67739060730875fe5cb321d82f562bfa9cf8d6f130013e89d77bd4b7a1daa3efeaf3f6ad846efaaa5ae5a2ef4308a24228548f35f19c51f5ec044ea9052dd3
+DIST ppsspp-1.16.2.tar.xz 51098300 BLAKE2B 48c3981a3b3f732281afe52140df25ed2c061ecc72fe88638f4c5854a447bc1a5a659272fa87d15d2174b6dc8164c226844dc1e2de4cd2088f0f9c423695e768 SHA512 ab3834651385e4f8a4728b27e7772da6a3821d96aa10ece9e15de1db3a7825bbf104aa1f5846de6f14c4b284db8d56d4757e77c4545305b300d1c296a2845f40
DIST ppsspp-1.16.tar.xz 50656132 BLAKE2B 5149bd859134a76a191e0f144bdcefc4c521276ebb1390fe5e24eeeb1227b77bab0458a760f29aed5ba169d566f12d5226f2b50a19e44172f1ad98c4eb8f400f SHA512 d65a8c9fb5d7ff45a99f5852d1071029bc51c1e8bdb45b3e78d961a46587553db4465bbd97b301db54a94b60772359929524047f08de3067cd3336f5f7717826
diff --git a/games-emulation/ppsspp/ppsspp-1.16.2.ebuild b/games-emulation/ppsspp/ppsspp-1.16.2.ebuild
new file mode 100644
index 000000000000..6093ddbdd308
--- /dev/null
+++ b/games-emulation/ppsspp/ppsspp-1.16.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit python-any-r1 xdg cmake
+
+DESCRIPTION="A PSP emulator written in C++"
+HOMEPAGE="https://www.ppsspp.org/
+ https://github.com/hrydgard/ppsspp/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hrydgard/${PN}.git"
+else
+ SRC_URI="https://github.com/hrydgard/${PN}/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0 BSD BSD-2 GPL-2 JSON MIT"
+SLOT="0"
+IUSE="discord qt5"
+RESTRICT="test"
+
+RDEPEND="
+ app-arch/snappy:=
+ app-arch/zstd:=
+ dev-libs/libzip:=
+ media-libs/glew:=
+ media-libs/libpng:=
+ media-libs/libsdl2[joystick]
+ media-video/ffmpeg:0/56.58.58
+ sys-libs/zlib:=
+ virtual/opengl
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[-gles2-only]
+ dev-qt/qtmultimedia:5[-gles2-only]
+ dev-qt/qtopengl:5[-gles2-only]
+ dev-qt/qtwidgets:5[-gles2-only]
+ )
+ !qt5? ( media-libs/libsdl2[X,opengl,sound,video] )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-CMakeLists-flags.patch
+ "${FILESDIR}"/${PN}-disable-ccache-autodetection.patch
+)
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DBUILD_SHARED_LIBS=OFF
+ -DCMAKE_SKIP_RPATH=ON
+ -DHEADLESS=false
+ -DUSE_SYSTEM_FFMPEG=ON
+ -DUSE_SYSTEM_LIBZIP=ON
+ -DUSE_SYSTEM_SNAPPY=ON
+ -DUSE_SYSTEM_ZSTD=ON
+ -DUSE_DISCORD=$(usex discord)
+ -DUSING_QT_UI=$(usex qt5)
+ )
+ cmake_src_configure
+}