summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-20 09:34:39 +0100
committerSam James <sam@gentoo.org>2023-05-20 10:20:43 +0100
commit62b536dbd360e84459e1c052b33b9aa5712502f2 (patch)
treef71d32f265e9686e05c74043d9556d1321fe6908
parentdev-ruby/ruby-rc4: DESCRIPTION tweak (diff)
downloadgentoo-62b536dbd360e84459e1c052b33b9aa5712502f2.tar.gz
gentoo-62b536dbd360e84459e1c052b33b9aa5712502f2.tar.bz2
gentoo-62b536dbd360e84459e1c052b33b9aa5712502f2.zip
dev-ruby/asciidoctor: add 2.0.20
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-ruby/asciidoctor/Manifest1
-rw-r--r--dev-ruby/asciidoctor/asciidoctor-2.0.20.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-ruby/asciidoctor/Manifest b/dev-ruby/asciidoctor/Manifest
index 5e1be13a2909..286d6853c011 100644
--- a/dev-ruby/asciidoctor/Manifest
+++ b/dev-ruby/asciidoctor/Manifest
@@ -1 +1,2 @@
DIST asciidoctor-2.0.18.tar.gz 1690964 BLAKE2B 5e14371c7201f83529fa28a63b031599ebf53fda62b4701942f134e7f1dae923a07676aafeac4c5e1fc3c25b6e9044b34b9b2e5b07491f1ca8e68076aa02301b SHA512 b47b377520046d95101fc9bcd3defdf7219714ebadc0d069cb108d39a349fcf1abd1e61178e1515f75bb69e9e3d0f8cb2de67de5a0f8aa75fdd139d693c0e437
+DIST asciidoctor-2.0.20.tar.gz 1700888 BLAKE2B 0b09610cc4a642eacd608bfbe8054c9358aca908adba088a21deceb25374fa4796a53a619957c9974fcb576016ce6573c891b39a6c6d66aa73585cd637310ff0 SHA512 b6b730de8f83e36630dc6146b4c0e07a26b502b695e78e50fc87790391126d52ef0b6b02b82ecb225adff680c94305b4e31403cc067bdbf1740e2d759417f440
diff --git a/dev-ruby/asciidoctor/asciidoctor-2.0.20.ebuild b/dev-ruby/asciidoctor/asciidoctor-2.0.20.ebuild
new file mode 100644
index 000000000000..db4ab72a2eb6
--- /dev/null
+++ b/dev-ruby/asciidoctor/asciidoctor-2.0.20.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_TASK_TEST="CUCUMBER_PUBLISH_QUIET=true test features"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.adoc README.adoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+RUBY_FAKEGEM_GEMSPEC="asciidoctor.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Processor for converting AsciiDoc into HTML 5, DocBook 4.5 and other formats"
+HOMEPAGE="https://github.com/asciidoctor/asciidoctor"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-util/cucumber
+ dev-ruby/rspec-expectations:*
+ dev-ruby/asciimath
+ dev-ruby/coderay
+ dev-ruby/concurrent-ruby
+ dev-ruby/erubi
+ dev-ruby/haml:6
+ dev-ruby/nokogiri
+ dev-ruby/rouge
+ dev-ruby/slim
+ dev-ruby/tilt )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+
+ sed -i -e "s:_relative ': './:" ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid broken blocks_test.rb (already appears to be fixed upstream)
+ rm -f test/blocks_test.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/asciidoctor.1
+}