summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2021-11-27 15:34:46 +0900
committerAkinori Hattori <hattya@gentoo.org>2021-11-27 15:39:05 +0900
commit62be5bffdc69157a8838a5699b09629fb465703b (patch)
treefcf32a20ee83f35a011087dbe4f5b55ccdfd4322
parentdev-scheme/stklos: update to EAPI 8 (diff)
downloadgentoo-62be5bff.tar.gz
gentoo-62be5bff.tar.bz2
gentoo-62be5bff.zip
dev-scheme/stklos: fix installation paths
Closes: https://bugs.gentoo.org/803914 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
-rw-r--r--dev-scheme/stklos/files/stklos-1.10-gentoo.patch40
-rw-r--r--dev-scheme/stklos/stklos-1.10-r2.ebuild4
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-scheme/stklos/files/stklos-1.10-gentoo.patch b/dev-scheme/stklos/files/stklos-1.10-gentoo.patch
new file mode 100644
index 000000000000..56f5440cf1dc
--- /dev/null
+++ b/dev-scheme/stklos/files/stklos-1.10-gentoo.patch
@@ -0,0 +1,40 @@
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -4,7 +4,6 @@
+ # Creation date: 11-Apr-2000 10:30 (eg)
+ # Last file update: 23-Oct-2010 11:52 (eg)
+
+-mandir = $(prefix)/share/man
+ man_MANS = stklos.1 stklos-config.1 stklos-compile.1 stklos-genlex.1 \
+ stklos-pkg.1
+ EXTRA_DIST = $(man_MANS)
+@@ -16,15 +16,13 @@
+ schemedir = $(prefix)/share/@PACKAGE@/@VERSION@
+ scheme_DATA = DOCDB
+
+-doclocation = $(prefix)/share/doc/@PACKAGE@-@VERSION@
+-
+-docpdfdir = $(doclocation)/pdf
++docpdfdir = $(pdfdir)
+ docpdf_DATA = pdf/stklos-ref.pdf
+
+-dochtmldir = $(doclocation)/html
++dochtmldir = $(htmldir)
+ dochtml_DATA= $(wildcard html/stklos-ref*.html) $(wildcard html/*.css)
+
+-docimgdir = $(doclocation)/html/images
++docimgdir = $(htmldir)/images
+ docimg_DATA = $(wildcard html/images/*)
+
+
+--- a/pkgman/Makefile.am
++++ b/pkgman/Makefile.am
+@@ -4,7 +4,7 @@
+ # Last file update: 4-Dec-2011 16:48 (eg)
+
+
+-makefiledir= $(prefix)/etc/stklos
++makefiledir= $(prefix)/share/@PACKAGE@/@VERSION@/etc
+ makefile_DATA= etc/Makefile-scmpkg.tmpl
+
+ bin_SCRIPTS = stklos-pkg
diff --git a/dev-scheme/stklos/stklos-1.10-r2.ebuild b/dev-scheme/stklos/stklos-1.10-r2.ebuild
index 6fd3a1acef34..72aa6c496083 100644
--- a/dev-scheme/stklos/stklos-1.10-r2.ebuild
+++ b/dev-scheme/stklos/stklos-1.10-r2.ebuild
@@ -3,6 +3,8 @@
EAPI="8"
+inherit autotools
+
DESCRIPTION="fast and light Scheme implementation"
HOMEPAGE="https://www.stklos.net/"
SRC_URI="https://www.${PN}.net/download/${P}.tar.gz"
@@ -18,12 +20,14 @@ RDEPEND="dev-libs/boehm-gc[threads?]
dev-libs/libpcre"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
DOCS=( AUTHORS ChangeLog NEWS PACKAGES-USED PORTING-NOTES README SUPPORTED-SRFIS )
src_prepare() {
rm -rf {ffi,gc,gmp,pcre}
default
+ eautoreconf
}
src_configure() {